Article ID: 951563 - Last Review: July 8, 2008 - Revision: 1.1

External e-mail message senders receive an NDR when you select the Turkish language setting on a computer that is running Exchange Server 2007 Service Pack 1

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SYMPTOMS

Consider the following scenario:
  • During Windows Setup, you set the regional language setting to Turkish on a Windows Server 2003-based computer.

    Note This means that you select Turkish in the Standards and formats section on the Regional Options tab and that you keep the United States setting in the Location section.
  • You install the Microsoft Exchange Server 2007 Service Pack 1 (SP1) Edge server role on the Windows Server 2003-based computer.
  • You configure the accepted domain setting by adding several authoritative domains to the accepted domain list.
In this scenario, external e-mail message senders receive the following non-delivery report (NDR) when they send e-mail messages to the Exchange server:
550 5.7.1 Unable to relay for user @ domain .com
Note External e-mail message senders receive this NDR even though the recipient addresses belong to accepted domains.

CAUSE

This problem occurs because the domain name of the recipient address in the affected messages includes the "i" character or the "I" character. In the Turkish alphabet, there is a lowercase and uppercase dotted i ('i' / 'İ') and also a lowercase and uppercase undotted ı ('ı' / 'I'). If the domain name does not match the accepted domain in any way, the Exchange server will convert the domain name to lowercase. However, "i" and "I" are treated as different characters in the Turkish regional setting.

RESOLUTION

Update information

Download and install Update Rollup 3 for Exchange Server 2007 SP1. For more information about Update Rollup 3 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 3 for Exchange Server 2007 Service Pack 1 (http://go.microsoft.com/fwlink/?LinkId=152557)
For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=152570)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 1, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbbug kbfix kbqfe kbhotfixrollup KB951563
 

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