Article ID: 116253 - Last Review: January 19, 2007 - Revision: 1.2

Err Msg: Missing Himem.sys. Make sure that the file is in your Windows directory and that its location is correctly specified in your CONFIG.SYS file.

This article was previously published under Q116253
Expand all | Collapse all

SYMPTOMS

When you try to load Windows, one of the following problems may occur:

  • Windows stops responding (hangs) at the logo screen.
  • Windows reports the following error message
    Missing <device name> Make sure that the file is in your Windows directory and that its location is correctly specified in your CONFIG.SYS file.
    where <device name> is a device such as HIMEM.SYS.

CAUSE

These problems can occur if you have added the NOAUTO parameter to the "DOS=" statement in the CONFIG.SYS file. For example:
   DOS=HIGH,UMB,NOAUTO
				

This parameter can also cause your computer to hang at the first Setup reboot because IFSHLP.SYS is not loaded.

RESOLUTION

  • Edit the Config.sys file and remove the NOAUTO parameter from the DOS= statement.

    -or-
  • Edit the Config.sys file and insert the required DEVICE= statements so that the necessary devices are loaded during startup. The required statements are as follows. Add these lines after the "DOS=HIGH,UMB,NoAuto" line:
    Device=C:\Windows\Himem.Sys
    Device=C:\Windows\iFSHLP.Sys
    NOTE: If Windows is installed in a folder other than the Windows folder, adjust the two lines as necessary to list the folder in which Windows is installed.
For additional information about how to edit the Config.sys file, click the article number below to view the article in the Microsoft Knowledge Base:
232558  (http://support.microsoft.com/kb/232558/EN-US/ ) How to Modify the Config.sys and Autoexec.bat Files

MORE INFORMATION

The NOAUTO parameter prevents Windows from loading devices such as HIMEM.SYS and IFSHLP.SYS automatically while booting. If you use this parameter, you must specify the devices that need to be loaded by adding them to the CONFIG.SYS file.

APPLIES TO
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kbprb KB116253
 

Article Translations

 

Related Support Centers