Article ID: 829427 - Last Review: October 26, 2005 - Revision: 1.7

FIX: "Failed to execute Regsvr32.exe error code 5" error message when you install Windows 2000 Service Pack 4 on a computer that is running IIS 5.0

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
Expand all | Collapse all

SYMPTOMS

When you install Microsoft Windows 2000 Service Pack 4 on a computer that is running Microsoft Internet Information Server (IIS) 5.0, you may receive the following error message:
"Failed to execute regsrv32.exe Error code: 5"
You may see the following error message in the Event Viewer:

Event ID: 4374
Source: NtServicePack
Description: "Windows 2000 Service Pack 4 installation failed, leaving Windows 2000 partially updated. An error in updating your system has occurred."

At this point, the service pack uninstalls, and the system reverts to the original configuration before the installation of the service pack.

CAUSE

The Iischema.dll file cannot update the IIS metabase.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

Microsoft recommends that you restart IIS after you apply this hotfix.

File information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Collapse this tableExpand this table
DateTimeVersionSizeFile name
07- Oct-200317:205.0.2195.6860122,640Iischema.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Internet Information Services 5.0
  • the operating system: Microsoft Windows 2000
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbwin2000presp5fix kbqfe kbbug kbfix KB829427
 

Article Translations

 

Related Support Centers