Unable to Read All Files from a Remote LAN Manager 2.1 Compatible Server

Article translations Article translations
Article ID: 219340 - View products that this article applies to.
This article was previously published under Q219340
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

When you read a file list from a remote LAN Manager 2.1-compatible server (for example, an OS/2 server) where the folder you are reading contains multiple files with names longer than 128 characters, the list of files displayed may not contain all files in the remote shared folder.

This does not affect folders shared on computers running Windows NT.

Cause

This problem occurs when there are multiple files on the shared folder with names longer than 128 characters. The internal buffers in the Windows NT redirector code does not account for the possiblity of these large names. The buffers have been expanded in Windows NT 4.0 Service Pack 5 to account for the largest possible names on these systems.

Resolution

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Status

Microsoft has confirmed that this is a problem in Windows NT 4.0. This problem was first corrected in Windows NT 4.0 Service Pack 5.

Properties

Article ID: 219340 - Last Review: February 21, 2014 - Revision: 3.0
Applies to
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix KB219340

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com