Article ID: 244166 - Last Review: January 25, 2007 - Revision: 1.2

Device Manager Only Contains a Computer Entry

This article was previously published under Q244166
Expand all | Collapse all

SYMPTOMS

When you choose to view devices by type in Device Manager, Device Manager may only contain a Computer entry.

CAUSE

This issue can occur if there is an incorrect version of the Setupx.dll file in the Windows\System folder.

RESOLUTION

To resolve this issue, rename all copies of the Setupx.dll file, and then extract a new copy of this file to the Windows\System folder:
  1. Click Start, point to Find, and then click Files Or Folders.
  2. In the Named box, type setupx.dll, and then click Find Now.
  3. Rename any copies of the Setupx.dll file you find to Setupx.1bk, Setupx.2bk, and so on. To rename a file, right-click it, type the new file name, and then press ENTER. If you are prompted to confirm changing a file extension, click Yes to do so.

    NOTE: By default, Windows does not display *.dll files. To have Windows display these files:

    1. Double-click My Computer.
    2. Click Folder Options on the View menu, click the View tab, and then click Show all files. Click to clear the Hide file extensions for known file types check box, and then click OK.
    3. Close all open windows.
  4. Extract a new copy of the Setupx.dll file to the Windows\System folder. For additional information about how to extract a file, click the article number below to view the article in the Microsoft Knowledge Base:
    129605  (http://support.microsoft.com/kb/129605/EN-US/ ) How to Extract Original Compressed Windows Files
  5. Restart your computer.

APPLIES TO
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kbenv kbprb kbui KB244166
 

Article Translations

 

Related Support Centers