Article ID: 246289 - Last Review: March 1, 2007 - Revision: 3.2

Installing Printer From Printer Share Across Security Boundary Generates "No Suitable Drivers..." Error Message

This article was previously published under Q246289

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SYMPTOMS

When you double-click a printer share and try to install it after you browse and connect to this share across security boundaries between enterprises, you may receive the following error message:
No suitable drivers were found for this printer.
You may then be prompted to select the appropriate drivers from a list. Also, you may receive this error message even if the server can provide the client computer that is attempting to connect with the correct drivers for this printer.

CAUSE

This problem can occur if the credentials of the client computer do not match any known accounts in the target domain or enterprise. When this occurs, the error message listed earlier in this article is generated, and the connection to the PRINT$ share for a driver download does not work.

RESOLUTION

To work around this problem, use any of the following methods:

Method 1

Establish a manual trust relationship.

Method 2

Enable guest access.

Method 3

Move the print server to the appropriate user's domain.

Method 4

Map a network connection to the IPC$ share on the other server. Note that you must supply the appropriate credentials to do so.

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
Keywords: 
kberrmsg kbnetwork kbprb kbprint KB246289
 

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