Article ID: 252331 - Last Review: October 27, 2006 - Revision: 3.2

XADM: Error Message: Failed to Get ADSI Object: 8007203A

This article was previously published under Q252331
Expand all | Collapse all

SYMPTOMS

When you use the DLUpdate script from the Microsoft BackOffice Resource Kit, version 4.5, you may receive the following error message:
Failed to get ADSI object:
8007203A:
Please contact your network administrator.

CAUSE

This problem can occur for either of the following reasons:
  • You need to hard-code the name of the Exchange Server computer in the script on which this script is running.
  • By default, the Active Directory Service Interface (ADSI) component communicates with the Exchange Server computer by using port 389. If the Lightweight Directory Access Protocol (LDAP) port number has been changed in Exchange Server, you must specify the correct port number in the script.

RESOLUTION

To resolve this problem, perform one of the following steps, as applicable:
  • To address the first cause that is listed in the "Cause" section of this article, assign the Exchange Server computer name to the strServer variable in the script, for example:
    strServer = "MYEXCHANGESERVER"
    NOTE: The name of the server is not case sensitive.
  • To address the second cause that is listed in the "Cause" section of this article, append a colon and the correct LDAP port number to the Exchange Server computer name in the strServer variable in the script, for example:
    strServer = "MYEXCHANGESERVER:390"

APPLIES TO
  • Microsoft Exchange Server 5.5 Standard Edition
Keywords: 
kbprb KB252331
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations