Article ID: 291528 - Last Review: February 28, 2007 - Revision: 3.5

Citrix ICA Client Automatic Logon Domain Name Not Filled In

This article was previously published under Q291528
Expand all | Collapse all

SYMPTOMS

Windows 2000 does not place the domain name in the logon dialog box for a remote Citrix ICA session if the user name is blank.

CAUSE

This behavior occurs because the Msgina.dll dynamic-link library (DLL) does not take a domain parameter that is passed from the remote session in the initialization of the logon dialog box if the user name is blank.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
   Date      Time    Version         Size     File name
   ----------------------------------------------------
   3/5/2001  01:58p  5.0.2195.3328   331,536  Msgina.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173  (http://support.microsoft.com/kb/265173/EN-US/ ) The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861  (http://support.microsoft.com/kb/296861/EN-US/ ) Use QChain.exe to Install Multiple Hotfixes with One Reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149  (http://support.microsoft.com/kb/249149/EN-US/ ) Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbsecurity kbwin2000presp3fix kbwin2000sp3fix KB291528
 

Article Translations