Explorer May Hang During the Detection of Audio Devices

Article translations Article translations
Article ID: 314405 - View products that this article applies to.
This article was previously published under Q314405
Expand all | Collapse all

SYMPTOMS

When Windows XP is detecting Plug and Play audio hardware, Explorer may become unresponsive or appear to stop responding (hang). This condition can also occur when physical removal or manual driver uninstallation is initiated.

CAUSE

This problem may be caused by an extremely rare timing condition that exists in the WinMM subsystem and is dependent upon several variables including response time of the new device, the bus to which it is being attached, and automatic installation of child drivers if this is a multiple-function device.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   21-Jul-2003  18:29  5.1.2600.1250  162,816  Winmm.dll

WORKAROUND

To immediately work around the problem, you can use Task Manager to end the Explorer.exe process, at which point Explorer will automatically restart. After Explorer restarts, restart your computer normally.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 314405 - Last Review: October 27, 2006 - Revision: 2.5
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbenv kbfix kbprb KB314405

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com