Error 80040E19 when you try to expand public folders in Exchange 2000 Server

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SYMPTOMS

When you try to expand the public folders tree in Microsoft Exchange System Manager, you may receive an error message that is similar to the following:
The Object is no longer available. Press F5 to refresh the display, and then try again.
ID no: 80040E19
Exchange System Manager
The Urlscan.log file may contain a record that is similar to one of the following:
  • Client at (IP_ADDRESS): URL contains extension '.com', which is disallowed. Request will be rejected. Raw URL='/ExAdmin/Admin/Domain_Name.com/Public%20Folders/'Client at (IP_ADDRESS): URL contains extension '.' in path. Request will be rejected. Site Instance='1', Raw URL='/ExAdmin/Admin/Domain_Name.com/Public%20Folders/Client at (IP_ADDRESS): URL contains disallowed header 'translate'. Request will be rejected. Raw URL='/ExAdmin/Admin/Domain_Name.com/Public%20Folders/Client at (IP_ADDRESS): sent verb 'OPTIONS', which is not specifically allowed. Request will be rejected.Client at (IP_ADDRESS): sent verb 'SEARCH', which is not specifically allowed. Request will be rejected.

CAUSE

This issue may occur if the URLScan tool rejects your request because of the settings that are specified in the Urlscan.ini file.

RESOLUTION

To resolve this issue, use either of the following methods.

Method 1

Modify the Urlscan.ini file:
  1. Open the c:\Windows folder\System32\Inetsrv\Urlscan folder.
  2. Open the Urlscan.log file in a text editor such a Notepad, and note the setting that is interfering with your request.
  3. Locate the setting in the Urlscan.ini file that corresponds to the record in the URLScan log file.
  4. Follow these steps to edit the Urlscan.ini file:
    1. Open the Urlscan.ini file.
    2. Locate the [DenyExtensions] section.
    3. Put a semicolon in front of the .com entry to remark out that line.
    4. Locate the [AllowExtensions] section.
    5. Add .com to the list of approved extensions.
    6. Save the Urlscan.ini file.
  5. Restart the IIS Administration service.
  6. Restart Exchange System Manager, and then try to expand Public Folders.
  7. If the issue is not resolved, repeat these steps. When you view the URLScan log file, note that a different parameter may be the cause of the issue. You may have to repeat this procedure several times until each parameter is approved by the URLScan tool.

Method 2

Remove IISLockDown by running Iislockd.exe, and then reinstall IISLockDown. Make sure that you do not install the URLScan tool.

MORE INFORMATION

For additional information about the IIS Lockdown and URLScan configuration with Microsoft Exchange 2000 Server and Microsoft Exchange Server 5.5, click the following article number to view the article in the Microsoft Knowledge Base:
309508 IIS lockdown and URLscan configurations in an Exchange environment
For additional information about the URLScan tool, click the following article number to view the article in the Microsoft Knowledge Base:
326444 How to configure the URLScan tool
For additional information about the URLScan tool, read the Urlscan.txt file. The Urlscan.txt file is located in the c:\Windows folder\System32\Inetsrv\Urlscan folder.

Properties

Article ID: 328659 - Last Review: October 26, 2013 - Revision: 6.2
APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbnosurvey kbarchive kbenv kberrmsg kbprb KB328659

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