Windows Removes Read-Only Driver Digital Signatures When You Restart with "Last Known Good Configuration" Option

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Article ID: 817434 - View products that this article applies to.
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SYMPTOMS

If your computer is running Microsoft Windows XP Service Pack 1 (SP1) and if you install a driver from read-only media (for example, from a CD-ROM), the driver files are marked as read-only. If you later select Last Known Good Configuration from the Windows Advanced Options menu when you start your computer, the digital signatures for the drivers are removed. The Device Manager then indicates that the driver is unsigned.

CAUSE

This problem occurs because the read-only driver files are also stored in the Windows\Lastgood.tmp folder, and zero-length OEMx.inf files are left in the Windows\Lastgood.temp\Inf folder. If these driver files and OEMx.inf files are deleted before you run Last Known Good Configuration, the problem does not occur.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

   Date         Time   Version        Size       File name
   --------------------------------------------------------------
   21-Mar-2003  23:56  5.3.16.5          24,576  Xpsp1hfm.exe     
   13-Dec-2002  01:08  5.1.2600.108   1,848,320  Ntkrnlmp.exe     
   13-Dec-2002  01:09  5.1.2600.108   1,902,080  Ntkrnlpa.exe     
   13-Dec-2002  01:09  5.1.2600.108   1,874,944  Ntkrpamp.exe     
   13-Dec-2002  01:08  5.1.2600.108   1,879,936  Ntoskrnl.exe     
   15-Nov-2002  22:05  5.1.2600.106      99,840  Services.exe     
   25-Mar-2003  18:05  5.1.2600.1190  1,895,936  Ntkrnlmp.exe     
   25-Mar-2003  18:05  5.1.2600.1190  1,951,744  Ntkrnlpa.exe     
   25-Mar-2003  18:05  5.1.2600.1190  1,923,584  Ntkrpamp.exe     
   25-Mar-2003  18:05  5.1.2600.1190  1,927,936  Ntoskrnl.exe     
   18-Dec-2002  02:20  5.1.2600.1152     99,840  Services.exe      

Windows XP 64-Bit Edition

   Date         Time   Version        Size       File name
   -----------------------------------------------------------------
   21-Mar-2003  23:55  5.3.16.5          59,904  Xpsp1hfm.exe  IA-64
   13-Dec-2002  01:09  5.1.2600.108   5,734,400  Ntkrnlmp.exe  IA-64
   13-Dec-2002  01:09  5.1.2600.108   5,677,568  Ntoskrnl.exe  IA-64
   15-Nov-2002  22:07  5.1.2600.106     330,240  Services.exe  IA-64
   25-Mar-2003  18:05  5.1.2600.1190  5,827,584  Ntkrnlmp.exe  IA-64
   25-Mar-2003  18:05  5.1.2600.1190  5,737,856  Ntoskrnl.exe  IA-64
   18-Dec-2002  03:23  5.1.2600.1152    330,240  Services.exe  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 817434 - Last Review: February 27, 2014 - Revision: 2.7
APPLIES TO
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1
  • Microsoft Windows XP 64-Bit Edition Version 2003
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB817434

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