Article ID: 818523 - Last Review: October 26, 2006 - Revision: 3.5

Dr. Watson Error Occurs When You Run a Program That Uses Utildll.dll

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SYMPTOMS

When you run a program that uses the Utildll.dll file (for example, Mfcfg.exe, the Citrix Connection Configuration utility), you may experience a Dr. Watson error.

CAUSE

This issue may occur if Utildll.dll uses the size of the buffer instead of the maximum number of TCHARs to call the QueryDosDevice function. In this scenario, QueryDosDevice reads past its buffer, and this may generate an access violation.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   15-Nov-2001  12:27                  5,149  Empty.cat
   14-Mar-2003  08:48  5.3.16.5        6,656  Spmsg.dll
   14-Mar-2003  08:51  5.3.16.5       89,088  Spuninst.exe
   17-Apr-2003  08:38  5.0.2195.6737  26,384  Utildll.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/EN-US/ ) New Naming Schema for Microsoft Windows Hotfix Packages

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB818523
 

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