Article ID: 839410 - Last Review: March 8, 2005 - Revision: 2.2

A problem occurs with custom forms that use the UserProperties.Find method and formulas in Outlook 2002 Service Pack 3

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SYMPTOMS

After you apply Microsoft Outlook 2002 Service Pack 3 (SP3), Outlook custom forms may not function correctly. The custom forms may exhibit a variety of problems that did not occur before you installed the service pack.

When you use the UserProperties.Find method with a custom field that contains a formula, the custom field value may change.

You may also receive the following error message:
The Operation Failed

CAUSE

When you use the UserProperties.Find method with a custom field that contains a formula, this may cause the custom field value to change. How the custom field value changes depends on the formula that is in the custom field.

You may receive the error message that is mentioned in the "Symptoms" section if the formula does not produce valid data for an Outlook field. For example, if you have a formula that sets a text field to a value of NULL, and you reference that field by using the UserProperties.Find method, you may receive the error message that is mentioned in the "Symptoms" section. Because NULL is not a valid value for an Outlook text field, an empty string ("") value must be used to set an Outlook text field to a blank value.

WORKAROUND

To work around this problem change the Microsoft VBScript code in the form so that the VBScript code uses the following syntax instead of using the UserProperties.Find method syntax:
UserProperties('fieldname')
To make this change, you can use the Replace command of the VBScript Editor. To do this, follow these steps:
  1. Open the form in Design mode.
  2. On the Form menu in the VBScript Editor, click View Code.
  3. On the Edit menu, click Replace.
  4. In the Find what box, type UserProperties.Find(.
  5. In the Replace with box, type UserProperties(.
  6. Click Replace All.
  7. Close the VBScript Editor.
  8. Republish the form.

RESOLUTION

A hotfix for this issue is currently in the development process. More information will be provided when the hotfix becomes available.

MORE INFORMATION

If you experience a problem with a custom form that only occurs after you install Outlook 2002 Service Pack 3, the problem that is described in this article is the probable cause.

If you cannot resolve the problem by following the steps in the "Workaround" section, the problem may be related to other design changes that were made in Outlook 2002 Service Pack 3. For additional information about other design changes that were made, click the following article number to view the article in the Microsoft Knowledge Base:
838871  (http://support.microsoft.com/kb/838871/ ) Description of the developer-related security changes in Outlook 2002 Service Pack 3 (S838871)

APPLIES TO
  • Microsoft Outlook 2002 Service Pack 2
Keywords: 
kbprb KB839410
 

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