Article ID: 884035 - Last Review: October 26, 2006 - Revision: 1.5

The Exchange Information Store service stops responding when you register an event sink on the system mailbox in Exchange 2000 Server

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SYMPTOMS

When you register a custom global information store event sink on a computer that is running Microsoft Exchange 2000 Server, the Microsoft Exchange Information Store service (Store.exe) may stop responding (hang).

CAUSE

This problem may occur if the following conditions are true:
  • You are running Exchange 2000 on a multi-processor computer.
  • You register the custom global store event sink on the system mailbox.
This problem occurs because Exchange may incorrectly free a structure before the Information Store service has finished working with it. This causes the Information Store service to stop responding (hang).

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378  (http://support.microsoft.com/kb/301378/ ) How to obtain the latest Exchange 2000 Server service pack
Additionally, this hotfix requires the update rollup package that is described in the following Microsoft Knowledge Base (KB) article:
870540  (http://support.microsoft.com/kb/870540/ ) Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -------------------------------------------------------------- 
   16-Sep-2004  22:00  6.0.6617.7      2,174,976  Exoledb.dll     

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexchange2000presp4fix kbbug KB884035
 

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