Article ID: 884860 - Last Review: October 26, 2006 - Revision: 1.5

The Microsoft Exchange Information Store service may unexpectedly quit on an Exchange 2000 computer

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SYMPTOMS

The Microsoft Exchange Information Store service (Store.exe) may unexpectedly quit. You do not receive an error message, no events or log entries are recorded, and you do not receive any other indicator of a problem.

CAUSE

This problem occurs when a stack overflow occurs on your Microsoft Exchange 2000 Server computer.

A stack is the memory space that each thread of a process uses to operate. A stack overflow occurs when a routine overwrites a part of the stack memory address that the routine does not allocate or own. This situation then causes problems for other routines. If the stack becomes large, insufficient memory may be reserved, and the operating system is therefore not able to handle these stack overflows correctly. The stack overflow that triggers the symptom that is described in this article may be caused by a third-party program.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378  (http://support.microsoft.com/kb/301378/ ) How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size       File name
--------------------------------------------------------------  
22-Oct-2004  07:54  6.0.6617.17     2,310,144  Mdbmsg.dll       
22-Oct-2004  08:50  6.0.6617.17     4,689,920  Store.exe
Component: MDB

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexchange2000presp4fix kbbug KB884860
 

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