Article ID: 885468 - Last Review: October 30, 2007 - Revision: 3.3

Public folder replication and send hierarchy replication may not be completed successfully in Exchange Server 2003

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SYMPTOMS

Public folder replication and send hierarchy replication, also known as hierarchy replication push, may not be completed successfully in Microsoft Exchange Server 2003. Additionally, you may receive an error message that is similar to the following:
Unexpected replication thread error 0x8004010f
When you try to view the Replication Status object for the mailbox store, you may also receive the following error message:
An unexpected, unknown error has occurred. MAPI or an unspecified service provider.
ID no: 8004010f-0000-0000000 ID no: c105010f

CAUSE

This problem occurs if the GUID on a row in the replication state table does not exist. Therefore, replication is not completed successfully because Exchange 2003 cannot verify that the GUID on the row exists.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires that you install Microsoft Exchange Server 2003 Service Pack 1 (SP1). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993  (http://support.microsoft.com/kb/836993/ ) How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you install this hotfix. However, the Microsoft Exchange Information Store service must be restarted when you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 
   Date          Time    Version       Size        File name
   ----------------------------------------------------------
   26-Oct-2004   20:05   6.5.7232.46   3,230,720   Mdbmsg.dll       
   26-Oct-2004   20:44   6.5.7232.46   5,139,968   Store.exe        

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about public folder replication in Exchange Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
823817  (http://support.microsoft.com/kb/823817/ ) Exchange Server 2003 public folder administration improvements
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
817903  (http://support.microsoft.com/kb/817903/ ) New naming schema for Exchange Server software update packages

APPLIES TO
  • Microsoft Exchange Server 2003 Service Pack 1
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbexchange2003presp2fix kbexchstore kbfix kbbug KB885468
 

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