Article ID: 889006 - Last Review: October 26, 2006 - Revision: 2.2

Users experience a slow response from an Exchange 2000 Server public folder server

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Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

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SYMPTOMS

On a computer that is running Microsoft Exchange 2000 Server, you may experience both the following symptoms:
  • Users experience a slow response from the Exchange 2000 Server computer when they access public folders.
  • If you monitor the performance of the Exchange Server computer, you notice that repeated remote procedure call (RPC) usage spikes occur. In this scenario, RPC requests are high, but RPC operations per second are low.

CAUSE

This problem may occur if the following conditions are true:
  • You have a public folder structure where many "child" public folders are created under a single "parent" public folder.
  • Each child public folder has its own access control list (ACL) entries defined.
In this scenario, every time the Exchange computer receives a new public folder replication message, the ACL for the parent public folder must be evaluated to determine the users who have rights to see the changes to the parent public folder. If the parent public folder has a large discretionary access control list (DACL) entry, it may take a long time to update the view for each public folder subscriber.

Note The DACL for the parent folder is made up of the sum of the DACLs of all the child public folders.

In this scenario, if you have many child public folders under a single parent public folder, and if most of those child public folders have their own ACL defined, there may be several megabytes (MB) of DACL data that must be parsed to update the display for all the public folder subscribers every time that a public folder replication message is received.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix has the following prerequisites:
  • You must be running Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information about how to obtain the latest Exchange 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
    301378  (http://support.microsoft.com/kb/301378/ ) How to obtain the latest Exchange 2000 Server service pack
  • You must have the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup installed. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
    870540  (http://support.microsoft.com/kb/870540/ ) Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, the following Microsoft Exchange services are automatically stopped and then restarted during the hotfix installation:
  • Microsoft Exchange POP3
  • Microsoft Exchange IMAP4
  • Microsoft Exchange Information Store

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Nov-2004  21:20  6.0.6617.23     2,330,624  Mdbmsg.dll       
   18-Nov-2004  22:17  6.0.6617.23     4,689,920  Store.exe   
				

WORKAROUND

To work around this problem, change your public folder hierarchy so that fewer child public folders appear under each parent public folder. In the scenario that is described in this article, we recommend that you reduce the number of child public folders that appear under each parent public folder to 250 or fewer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install this hotfix, four new events are logged to notify you if one or both the following behaviors occur:
  • DACL enumeration takes longer than expected. By default, this event is logged if DACL enumeration takes 20 seconds or longer.
  • The publication of public folder notification messages takes longer than expected. By default, this event is logged if notification publication takes 60 seconds or longer.
In this scenario, one of more of the following events are logged:

Event ID 1236
Event Source: MSExchangeIS
Event Category: General
Event Type: Warning
Description:
Publication of a notification notification to n subscribers (n estimated) of folder FolderName in database "DatabaseName" succeeded, but took an abnormally long time (NumberOf seconds) to complete. This latency may be indicative of the notified folder or its parent having too many child folders with differing access rights. It may also be indicative of performance problems with your hardware.

Event ID 1237
Event Source: MSExchangeIS Event Category: General
Event Type: Error
Description:
Publication of a notification notification to n subscribers (n estimated) of folder FolderName in database "DatabaseName" failed with error ErrorCode, and took an abnormally long time (NumberOf seconds) to do so. This latency may be indicative of the notified folder or its parent having too many child folders with differing access rights. It may also be indicative of performance problems with your hardware.

Event ID 1238
Event Source: MSExchangeIS
Event Category: General
Event Type: Warning
Description:
Enumeration of NumberOf entries for the ACL of folder FolderName in database "DatabaseName" succeeded, but took an abnormally long time (NumberOf seconds) to complete. This latency may be indicative of the folder having too many child folders with differing access rights. It may also be indicative of performance problems with your hardware.

Event ID 1239
Event Source: MSExchangeIS
Event Category: General
Event Type: Error
Description:
Enumeration of NumberOf entries for the ACL of folder FolderName in database "DatabaseName" failed with error %5, and took an abnormally long time (NumberOf seconds) to do so. This latency may be indicative of the folder having too many child folders with differing access rights. It may also be indicative of performance problems with your hardware.

You can control how often these events are triggered. To do this, modify the following registry subkeys.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  • To change the DACL enumeration threshold, modify the value of the Abnormal OFLIST Enumerate Latency Threshold entry in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    Entry name: Abnormal OFLIST Enumerate Latency Threshold
    Value type: REG_DWORD
    Value data: 20000 (default)
  • To change the public folder notification message publication threshold, modify the value of the Abnormal Publish Latency Threshold entry in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    Entry name: Abnormal Publish Latency Threshold
    Value type: REG_DWORD
    Value data: 60000 (default)
These registry values must be specified in milliseconds. If one or both these registry subkeys do not exist, or if the value is 0 (zero), or if the value is a negative value, the default value is used.

For additional information about Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
817903  (http://support.microsoft.com/kb/817903/ ) New naming schema for Exchange Server software update packages

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexchange2000presp4fix kbbug KB889006
 

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