Article ID: 890459 - Last Review: October 26, 2006 - Revision: 1.4

A memory leak occurs when you repeatedly open and close the Microsoft Exchange Information Store service performance counters on a remote computer

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SYMPTOMS

Consider the following scenario. Microsoft Exchange 2000 Server is installed on a Microsoft Windows 2000-based computer. Additionally, you use a Microsoft Windows XP-based computer or a Windows 2000-based computer to remotely monitor the Microsoft Exchange Information Store service performance counters on the Exchange server. When you repeatedly open and close the Microsoft Exchange Information Store service performance counters on the remote computer, a memory leak occurs.

If you use the Performance Monitor tool (Perfmon.msc) to view the Handle Count counter for the Remote Registry service (Regsvc.exe) on the Exchange server, you may find that the Handle Count counter continues to increase.

Note You can use either the Performance Monitor tool or a user-created application to remotely monitor the Microsoft Exchange Information Store service performance counters. However, this problem occurs more frequently if you use a user-created application to monitor the Microsoft Exchange Store service performance counters.

CAUSE

This problem occurs if the Mdbperf.dll component leaks handles in the Remote Registry service. When the Mdbperf.dll component leaks handles in the Remote Registry service, a memory leak occurs.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378  (http://support.microsoft.com/kb/301378/ ) How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version       Size     File name
   --------------------------------------------------------
   28-Jan-2005   18:57   6.0.6617.41   49,152   Mdbperf.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbexchstore kbqfe kbfix kbexchange2000presp4fix kbbug kbpubtypekc KB890459
 

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