Article ID: 892615 - Last Review: February 14, 2005 - Revision: 1.3

You receive an error message when you check the spelling and grammar in a Works 7.0 or in a Works 8.0 Word Processor document

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SYMPTOMS

When you check the spelling and grammar in a Microsoft Works 7.0 or in a Microsoft Works 8.0 Word Processor document, you may receive the following error message:
Works Word processor has encountered a problem and needs to close.
If you click Click Here, you receive an error signature that contains the following details:
Error Signature
AppName: wkswp.exe AppVer: <AppVer number> ModName: riched20.dll
ModVer: <ModVer number>

CAUSE

This issue may occur if your printer driver is corrupted or outdated.

RESOLUTION

Use an alternative printer driver

You may be able to resolve this issue by using an alternative printer driver. You may also follow these steps to make sure that the grammar and spelling checker tools work correctly before you remove the corrupted printer driver. To do this, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Printers.
  2. Double-click Add Printer.
  3. Click Next, click Local printer, and then click Next.
  4. Click LPT1, and then click Next.
  5. Under Manufacturers, select the manufacturer of your printer.
  6. Under Printers, select your printer model or the printer model that the manufacturer instructed you to use, and then click Next.
  7. Click Yes to make this printer the default printer, and then click Next. When you are prompted to print a test page, click No, and then click Finish.
  8. Open a Works Word Processor document and make sure that the grammar and spelling checker tools work correctly.
Note After you install the most recent printer driver provided by the manufacturer of your printer as detailed in the "Install the most recent printer" section, remove the alternative printer driver that you installed.

Remove the corrupted printer driver

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Install/Uninstall tab, click the current printer driver, and then click Add/Remove. Follow the instructions that appear on the screen to remove the printer driver.
If your printer driver is not listed on the Install/Uninstall tab, follow these steps:
  1. Click Start, point to Settings, and then click Printers.
  2. Right-click the current printer, and then click Delete. If you are prompted to remove additional files from the system, click Yes.

Install the most recent printer

Install the most recent printer driver that is provided by the manufacturer of your printer. For more information, see the documentation that is provided with your printer.

For information about your hardware manufacturer, visit the following Web site:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)

APPLIES TO
  • Microsoft Works 7.0
  • Microsoft Works 8.0
Keywords: 
kbtshoot KB892615
 

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