Article ID: 902962 - Last Review: October 25, 2007 - Revision: 2.4

Users may not be replicated to the Lotus Domino server when you synchronize the directory from Exchange Server 2003 to Lotus Domino

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
817903  (http://support.microsoft.com/kb/817903/ ) New naming schema for Exchange Server software update packages

On This Page

Expand all | Collapse all

SYMPTOMS

When you try to synchronize Active Directory objects from a computer that is running Microsoft Exchange Server 2003 to a computer that is running IBM Lotus Domino server, some users may not be replicated to the Domino server.

Additionally, when you view the event log, an event that is similar to the following event appears:

Event Type: Warning Event
Source: MSExchangeADDXA Event
Category: Replication
Event ID: 8340
Date:  Date
Time:   Time
User: not applicable
Computer:  Computer_Name
Description: ADC could not replicate Relative_Distinguished_Name because it is secured and the connection agreement does not allow secured objects to replicate.  

CAUSE

This problem may occur if the Active Directory object that is not replicated is secured with an explicit Deny access control entry.  

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Exchange Server 2003 Service Pack 2 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Addxa.dll6.5.7651.3566,27210-Feb-200602:33x86
Dxamex.dll6.5.7651.336,86410-Feb-200602:34x86

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.After you install this hotfix, you must change the registry to enable the hotfix. To change the registry, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Expand the following key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LME-NOTES\Parameters
  3. Right-click Parameters, point to New, and then click DWORD Value.
  4. Type DXAMEX_ReplicateSecuredObjects, and then press ENTER to name the new subkey.
  5. Right-click DXAMEX_ReplicateSecuredObjects, and then click Modify.
  6. In the Value data box, type 1, and then click OK.

    Note If the value of the DXAMEX_ReplicateSecuredObjects subkey is zero, secured Active Directory objects are not replicated.
  7. Close Registry Editor.
Alternatively, you can change or add the ReplicateSecuredObjects entry in the Exchconn.ini file to enable this hotfix. To do this, follow these steps:
  1. Open the Exchconn.ini file. Typically, this file is located in the following folder:
    C:\Program Files\Exchsrvr\bin
  2. Locate the [LME-NOTES-DXAMEX] section.
  3. Locate ReplicateSecuredObjects= FALSE, and change FALSE to TRUE so that the entry is ReplicateSecuredObjects= TRUE.

    Note If ReplicateSecuredObjects= FALSE does not exist, type ReplicateSecuredObjects= TRUE at the bottom of the [LME-NOTES-DXAMEX] section.
  4. Click File, click Save, and then close the Exchconn.ini file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Keywords: 
kbautohotfix kbexpertiseinter kbqfe kbhotfixserver kbfix kbbug kbexchange2003presp2fix kbpubtypekc KB902962
 

Article Translations

 

Related Support Centers