Article ID: 903245 - Last Review: February 21, 2007 - Revision: 2.4

In Exchange 2000 Server, the Microsoft Exchange Information Store service stops responding, and a Dr. Watson access violation error is generated in the EcParseTransferSD function

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SYMPTOMS

In Microsoft Exchange 2000 Server, the Microsoft Exchange Information Store service (Store.exe) stops responding. Additionally, a Dr. Watson access violation error is generated in the EcParseTransferSD function.

CAUSE

This problem occurs when the PR_NT_SECURITY_DESCRIPTOR property is set to NULL and is passed to the EcParseTransferSD function.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install Microsoft Exchange 2000 Server SP3 and the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup before you install the hotfix.

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
301378  (http://support.microsoft.com/kb/301378/ ) How to obtain the latest Exchange 2000 Server service pack
870540  (http://support.microsoft.com/kb/870540/ ) Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart the computer after you install the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   ---------------------------------------------------------
   27-Jul-2005  02:19  6.0.6617.81     2,342,912  Mdbmsg.dll
   27-Jul-2005  03:09  6.0.6617.81     4,710,400  Store.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexchange2000presp4fix kbbug kbpubtypekc KB903245
 

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