Error message when you run the Setup program to install Windows Small Business Server 2003 R2: "Setup has encountered an error and cannot continue"

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Article ID: 932441 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

When you run the Setup program to install Microsoft Windows Small Business Server 2003 R2, the Setup program crashes. Additionally, you receive the following error message:
Error
Setup has encountered an error and cannot continue.
When you click OK, you receive the following error message:
Setup.exe has encountered a problem and needs to close.
If you click View the contents of the error report to view the contents of the Setup.crash file, you see information that resembles the following:
[Crash Information]
ReportVersion=1 MainBinary=Drive:\CD6\sbs\setup.exe
MainBinaryVersion=5.2.3580.0
CrashTime=Date Time UTC
Exception=System.InvalidOperationException
HResult=80131509
ExceptionMessage=Process performance counter is disabled, so the requested operation cannot be performed.

[Stack Trace]
IP=0x7b2b31a8+1a5 System.Diagnostics.NtProcessManager.GetProcessInfos(System.Diagnos tics.PerformanceCounterLib library)
IP=0x7b2b30e8+a4 System.Diagnostics.NtProcessManager.GetProcessInfos(System.String machineName, System.Boolean isRemoteMachine)
IP=0x7b2b16c0+29 System.Diagnostics.ProcessManager.GetProcessInfos(System.String machineName)
IP=0x7b2aed70+116 System.Diagnostics.Process.EnsureState(System.Diagnostics.Process+ State state)
IP=0x7b2ae240+11 System.Diagnostics.Process.get_ProcessName()
IP=0x02e307f8+1ce2 R2_SetupWizard.MainClass.Main(System.String[] args)

CAUSE

This issue occurs if the Perfproc performance counters are disabled, are missing, or are not working correctly.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, make sure that the Perfproc performance counters are enabled. Then, run the Setup program again. To enable the Perfproc performance counters, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance
  3. Right-click Disable Performance Counters, and then click Modify.
  4. In the Value data box, type 0 (zero), and then click OK.
  5. Exit Registry Editor.

MORE INFORMATION

For more information about Windows Small Business Server 2003 R2, visit the following Microsoft Web site:
Technical Resources for Windows Small Business Server 2003
http://www.microsoft.com/windowsserver2003/sbs/techinfo/default.mspx

Properties

Article ID: 932441 - Last Review: February 22, 2007 - Revision: 1.0
APPLIES TO
  • Microsoft Windows Small Business Server 2003 R2 Premium Edition
  • Microsoft Windows Small Business Server 2003 R2 Standard Edition
Keywords: 
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