Article ID: 936920 - Last Review: June 18, 2007 - Revision: 2.0

File operations may stop responding on a Windows 2000-based computer

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SYMPTOMS

When you try to perform a file operation, such as saving data or retrieving data on a Microsoft Windows 2000-based computer, the file operation may stop responding (hang). Therefore, you cannot access the volume in question.

CAUSE

This issue may occur if the Windows 2000 NTFS log file is full.

RESOLUTION

For more information about how to resolve this issue, click the following article number to view the article in the Microsoft Knowledge Base:
817075  (http://support.microsoft.com/kb/817075/ ) How to identify and troubleshoot NTFS log file size bottlenecks in Windows 2000 Server

MORE INFORMATION

When the Windows 2000 NTFS log file is full, the checkpoint process starts. The checkpoint process requires exclusive access to the Volume Control Block (VCB). However, the checkpoint process may be blocked from accessing the VCB if another thread already has exclusive access to the VCB. If the checkpoint process is blocked, and if the process cannot continue, other file operations may not be completed..

This issue typically occurs when the NTFS log file becomes full because the computer is under stress. Or, this issue may occur if file-system filter drivers are installed on the computer.

APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbtshoot kbprb KB936920
 

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