How to use the Process Monitor tool to generate a log file for an application in the App-V (SoftGrid) virtual environment

Article translations Article translations
Article ID: 939896 - View products that this article applies to.
Expand all | Collapse all

On This Page

INTRODUCTION

This article describes how to use the Process Monitor tool (ProcMon.exe) to generate a log file for an application in the Microsoft App-V (SoftGrid) virtual environment. The log file provides information about the files and about the registry keys that the application accesses when Process Monitor is running. 

MORE INFORMATION

How to obtain Process Monitor

  1. Download Process Monitor. To do this, visit the following Microsoft Web site:
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
  2. Click Download Process Monitor (913K), and then click Save.
  3. Save the file in a folder of your choice.
  4. Right-click the file that you downloaded, and then click Extract to.
  5. Specify where you want to extract the file, and then click Extract.

How to prepare Process Monitor

  1. In the folder to which you extracted the file, double-click the Procmon.exe file.
  2. Click Agree to accept the license terms.
  3. On the Options menu, click Enable Advanced Output.
  4. On the Edit menu, click Auto Scroll.
  5. On the File menu, click Exit to close Process Monitor.

How to prepare the App-V (SoftGrid) virtual application

  1. When you troubleshoot an application, open the content share of the application, and then edit the .osd file of the application to add a cmd.exe command.

    To do this, add the following lines after the <DEPENDENCY> tag.
    <SCRIPT EVENT="LAUNCH" TIMING="PRE" PROTECT="FALSE" WAIT="TRUE" TIMEOUT="0">
    <SCRIPTBODY>cmd.exe</SCRIPTBODY>
    </SCRIPT>
    
  2. On the App-V (SoftGrid) client computer, start the App-V (SoftGrid)Client Management Microsoft Management Console (MMC) snap-in. If the application already exists under Applications, remove it so that the new .osd file is used the next time that you run the application.

How to generate the log file for the application

  1. On the App-V (SoftGrid) client computer, start the App-V (SoftGrid) virtual application.

    Note When you do this, a command prompt appears on the desktop before the application starts.
  2. At the command prompt, type procmon.exe, and then press ENTER to start Process Monitor.
  3. Close the command prompt.

    Note When you do this, Process Monitor starts.
  4. Reproduce the issue.
  5. On the File menu, click Save to save the Process Monitor log file.
  6. Under Events to save, click to select the All events check box.
  7. Under Format, click to select the Native Process Monitor Format (PML) check box.
  8. In the Path box, specify a location on the local hard disk where you want to save the file.

Properties

Article ID: 939896 - Last Review: October 12, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft Application Virtualization for Terminal Services
  • Microsoft Application Virtualization for Windows Desktops
  • Microsoft Application Virtualization 4.6 for Terminal Services
  • Microsoft Application Virtualization 4.6 for Windows Desktops
  • Microsoft Application Virtualization 4.5 for Terminal Services
  • Microsoft Application Virtualization 4.5 for Windows Desktops
Keywords: 
kbexpertiseinter kbhowto kbinfo KB939896

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com