You receive occasional Stop errors after you install a driver that manages on-board flash memory on a Windows Vista-based computer

Article translations Article translations
Article ID: 941020 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

On a Windows Vista-based computer, you install a third-party driver that manages on-board flash memory for ReadyDrive. After you install this third-party driver, you occasionally receive a Stop error message that resembles the following:
*** STOP: 0x0000007F (parameter1, parameter2, parameter3, parameter4)
UNEXPECTED_KERNEL_MODE_TRAP

CAUSE

This problem occurs because of an issue in the third-party flash memory driver. This problem only occurs when the system experiences a low-memory condition. The Ecache.sys driver that is included in Windows Vista uses large amounts of memory during startup to cache data. Otherwise, the data would be read directly from the hard disk drive. The cached data improves Windows Vista start times.

The version of Ecache.sys that is included in this hotfix uses memory less aggressively. After you install this hotfix, low-memory conditions are less likely to occur. Therefore, the problem that is described in the "Symptoms" section is also less likely to occur.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable2,02409-Aug-200715:45Not Applicable
X86_d9e44a8dde59eff0e44824b51998f912_31bf3856ad364e35_6.0.6000.20657_none_1b72dbc378b4e445.manifestNot Applicable1,07509-Aug-200715:45Not Applicable
X86_microsoft-windows-e..emorydevicesservice_31bf3856ad364e35_6.0.6000.20657_none_9d003af812d3b004.manifestNot Applicable50,69209-Aug-200715:45Not Applicable
X86_microsoft-windows-e..memorydevicesdriver_31bf3856ad364e35_6.0.6000.20657_none_f996c4b2d59c4c1b.manifestNot Applicable4,49209-Aug-200715:45Not Applicable
Emdmgmt.dll6.0.6000.20657563,20009-Aug-200702:21x86
Emdperf.hNot Applicable92407-Jan-200705:51Not Applicable
Emdperf.iniNot Applicable5,10007-Jan-200705:51Not Applicable
Ecache.sys6.0.6000.20657135,86409-Aug-200702:30x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_56d40947016b2391848ea48f87987309_31bf3856ad364e35_6.0.6000.20657_none_3a439d34823c9a67.manifestNot Applicable1,08109-Aug-200715:45Not Applicable
Amd64_microsoft-windows-e..emorydevicesservice_31bf3856ad364e35_6.0.6000.20657_none_f91ed67bcb31213a.manifestNot Applicable50,72809-Aug-200715:49Not Applicable
Amd64_microsoft-windows-e..memorydevicesdriver_31bf3856ad364e35_6.0.6000.20657_none_55b560368df9bd51.manifestNot Applicable4,49809-Aug-200715:49Not Applicable
Update.mumNot Applicable2,02409-Aug-200715:45Not Applicable
Emdmgmt.dll6.0.6000.20657397,31209-Aug-200703:16x64
Emdperf.hNot Applicable92407-Jan-200705:51Not Applicable
Emdperf.iniNot Applicable5,10007-Jan-200705:51Not Applicable
Ecache.sys6.0.6000.20657145,59209-Aug-200703:22x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 941020 - Last Review: May 20, 2008 - Revision: 2.1
APPLIES TO
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Starter
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbbug kbfix kbexpertiseinter kbwinvistapostrtmfix kbqfe kbhotfixserver KB941020

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com