Article ID: 945645 - Last Review: November 28, 2007 - Revision: 1.0

Cannot Migrate Lotus Notes User to Exchange Server 2007 Because UserPrincipalName Is Not Set

Expand all | Collapse all
Source: Microsoft Support

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Action



Try to migrate users from Lotus Notes to Exchange Server 2007 by using Lotus Transporter Suite.

Result

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:08

TestUser
Failed

Error:
Error: User TestUser/OU/O could not be migrated to ExchangeServer.

Warning:
Error: User TestUser can not be enabled.

Exchange Management Shell command attempted:
'CN=TestUser/OU=OU/O=O' | move-dominouser -Quiet -DominoDirectoryServer $null -DomainController 'DC' -TargetOU 'OU=Migrated to Lotus Notes,DC=Test' -InitialPassword 'System.Security.SecureString' -TargetMailboxDatabase 'ExchangeServer\SG\DB'

Elapsed Time: 00:00:08

Cause

The user's UserPrincipalName is not set.

Resolution



To set UserPrincipalName with a user's email address properly:

1. Click Start -> Run... -> Type "adsiedit.msc" and Click OK.
2. Right Click the user and Click Properties.
3. DoubleClick the UserPrincipalName.
4. Input user's email address and Click OK.

DISCLAIMER

MICROSOFT CORPORATION AND/OR ITS RESPECTIVE SUPPLIERS MAKE NO REPRESENTATIONS ABOUT THE SUITABILITY, RELIABILITY, OR ACCURACY OF THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN. ALL SUCH INFORMATION AND RELATED GRAPHICS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT AND/OR ITS RESPECTIVE SUPPLIERS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS INFORMATION AND RELATED GRAPHICS, INCLUDING ALL IMPLIED WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, WORKMANLIKE EFFORT, TITLE AND NON-INFRINGEMENT. YOU SPECIFICALLY AGREE THAT IN NO EVENT SHALL MICROSOFT AND/OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, INDIRECT, PUNITIVE, INCIDENTAL, SPECIAL, CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF USE, DATA OR PROFITS, ARISING OUT OF OR IN ANY WAY CONNECTED WITH THE USE OF OR INABILITY TO USE THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT LIABILITY OR OTHERWISE, EVEN IF MICROSOFT OR ANY OF ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF DAMAGES.

APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbnomt kbrapidpub KB945645
 

Article Translations

 

Related Support Centers