Article ID: 952928 - Last Review: January 26, 2009 - Revision: 1.1

Users cannot delete or modify their own e-mail messages from a mail-enabled public folder in an Exchange Server 2007 environment

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SYMPTOMS

Consider the following scenario.
  • In a Microsoft Exchange 2007 environment, you create a mail-enabled public folder.
  • You have only Author permissions on the public folder.
  • You send an e-mail message to the mail-enabled public folder.
  • In Microsoft Office Outlook 2003 or Outlook 2007, you try to delete or modify the e-mail message:
In this scenario, you receive an error message that resembles the following:
Microsoft Office Outlook - The item could not be deleted. It was either moved or already deleted, or access was denied.
Note You can delete or modify your own postings to the public folder.

Note The problem does not occur if you have Owner permissions on the public folder.

CAUSE

This problem occurs because the sender's permission settings are not preserved when a user sends the e-mail message to the public folder. Therefore, the store cannot relate the initial author of the e-mail message to the creator of the e-mail message. Any modification of that item is denied.

WORKAROUND

To work around this problem, use one of the following methods:
  • Give the user full owner permissions on the public folder.
  • Use the post method instead of sending the e-mail message to the public folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbtshoot kbexpertiseinter kbprb KB952928
 

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