Article ID: 959960 - Last Review: January 30, 2009 - Revision: 1.0

When you move mailboxes from an Exchange Server 2003 computer to a continuous cluster replication (CCR) Exchange Server 2007 environment, all mail for some users may be put in the Deleted Items folder

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario. You are running Microsoft Exchange Server 2007 in a continuous cluster replication (CCR) environment. You move mailboxes from a computer that is running Microsoft Exchange Server 2003 to a computer that is running Exchange Server 2007. In this scenario, you notice the following symptoms:
  • In some mailboxes, you see that all mail was moved to the Deleted Items folder.
  • Although you save the mail in an affected mailbox to a .pst file, and then you import the .pst file in a newly created mailbox for the user, the problem remains.

CAUSE

This problem occurs because the affected mailboxes have the Automateprocessing parameter set to autoaccept instead of autoupdate, as expected

RESOLUTION

To resolve this problem, use one of the following methods, as appropriate for your situation.

Method 1: Change the parameter for one mailbox

  1. Open an Exchange Management Shell command prompt.
  2. Run the following cmdlet:
    set-mailboxcalendarsettings username -automateprocessing: Autoupdate

Method 2: Change the parameter for multiple mailboxes

To change the option for the Automateprocessing parameter for multiple mailboxes, follow these steps:
  1. Open the Exchange Management Shell.
  2. To determine for which mailboxes the autoaccept option is set, run the following cmdlet:
    get-mailbox | get-mailboxcalendarsettings | where {$_.automateprocessing -eq "autoaccept"} | ft identity, automateprocessing
  3. To change the autoaccept option on the mailboxes to the autoupdate option, run the following cmdlet:
    get-mailbox | get-mailboxcalendarsettings | where {$_.automateprocessing -eq "autoaccept"} | Set-MailboxCalendarSettings -AutomateProcessing autoupdate
  4. To verify that the autoaccept option is not set for any mailboxes, run the following cmdlet:
    get-mailbox | get-mailboxcalendarsettings | where {$_.automateprocessing -eq "autoaccept"} | ft identity, automateprocessing
    This command should not return any mailboxes in the output.

APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbsurveynew kbautoupdate kbexpertiseadvanced kbprb kbtshoot KB959960
 

Article Translations

 

Related Support Centers