Article ID: 960908 - Last Review: December 17, 2008 - Revision: 1.1

When you replicate public folders to a computer that is running Exchange Server 2003, the nonpaged pool leaks memory

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SYMPTOMS

When you replicate public folders to a computer that is running Microsoft Exchange Server 2003, the nonpaged pool leaks memory. The server stops responding until you restart the Microsoft Exchange Information Store service.

The memory leak trace may show that the nonpaged pool memory is filled by AuxL nonpaged pool tags. These tags are used by the Exifs.sys driver. This is the kernel-mode driver that the Exchange store driver uses to read and write items to and from the messaging databases.

CAUSE

This issue occurs because of the content conversion of SMTP/MIME messages that are sent to the public folders.

All incoming public folder replication messages are stored in the .STM file and then converted to MAPI format. Incoming replication messages reserve space in the .STM file during MAPI conversion. If the user traffic in the Exchange server is low, the space in the .STM file that is reserved by incoming replication messages is not reused. The information store keeps a track of reserved space and free space in the store and allocates memory efficiently when it is requested by incoming replication messages. If no user data requires space in the .STM file, the “free lists" become larger, and they eventually consume all available kernel memory.

RESOLUTION

To resolve this issue, unmount and then remount the public folder store.

You can schedule a task to run the following script after business hours. The script unmounts and then remounts the public folder store.
Set oDB = CreateObject("CDOEXM.PublicStoreDB") 
strDB = "DN of the Public Store" 
oDB.DataSource.Open strDB 
oDB.Dismount() 
oDb.Mount()
Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure. However, they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
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