FIX: The EDIMessageContent table is not purged correctly when DTA Archive and Purge job is run in BizTalk Server 2006 R2

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Article ID: 961330 - View products that this article applies to.
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SYMPTOMS

In Microsoft BizTalk Server 2006 R2, the DTA Purge and Archive SQL Server Agent job purges old data from the BizTalk Tracking (BizTalkDTADb) database. However, the EDIMessageContent table is not purged correctly. Every time that the DTA Purge and Archive job is run, only 100 rows are purged from the EDIMessageContent table. Therefore, after BizTalk Server has been running for some time, the EDIMessageContent table grows very large. Because of this, performance may be slow when you query the EdiMessageContent table.

CAUSE

This issue occurs because of a problem in the dtasp_PurgeTrackingDatabase stored procedure of the BizTalkDTADb database.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Installation Information

This hotfix updates the BizTalkDTADb database. To avoid errors and unexpected crashes during the installation of the hotfix, follow these steps:
  1. Stop the SQL Server Agent service that is running the BizTalk SQL Server Agent jobs.
  2. Stop the Internet Information Services (IIS) service to stop all isolated BizTalk host instances.
  3. Stop all BizTalk host instances that are running in the BizTalk group in which you are experiencing the problem.
  4. Install this hotfix.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

After you install this hotfix, restart the SQL Server Agent service, the IIS service, and the BizTalk host instances.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Bts_tracking_logic.sqlNot applicable328,46612-Feb-200914:15Not applicable

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to archive and purge the BizTalk tracking database, visit the following Microsoft Web sites:
http://technet.microsoft.com/en-us/library/dd802818.aspx
http://technet.microsoft.com/en-us/library/dd745781.aspx
For more information about the EDIMessageContent table, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/dd745126.aspx

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 961330 - Last Review: July 13, 2009 - Revision: 1.1
APPLIES TO
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch Edition
Keywords: 
kbbtsmessaging kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe KB961330

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