Article ID: 970071 - Last Review: May 21, 2009 - Revision: 2.0

You are prompted for credentials for a POP3 e-mail account in Outlook 2007

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SYMPTOMS

In Microsoft Office Outlook 2007, when you try to create a POP3 e-mail account, you select the Require logon using Secure Password Authentication (SPA) check box. However, you do not type a password, and you do not select the Remember password check box in the Add New E-mail Account dialog box. In this case, when you click Test Account Settings to test the account settings, you are prompted for your credentials. Additionally, you are prompted for your credentials every time that you start Outlook.

CAUSE

This problem occurs because Outlook 2007 does not use your Windows logon credentials.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


To resolve this problem, apply the Outlook 2007 hotfix package that is dated April 30, 2009, and set a value for the AlwaysUseCachedCredsForSPA registry entry. To do this, follow these steps:
  1. Apply the Outlook 2007 hotfix package that is dated April 30, 2009.
    For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    968858  (http://support.microsoft.com/kb/968858/ ) Description of the Outlook 2007 hotfix package (Outlook.msp): April 30, 2009
  2. Set a value for the AlwaysUseCachedCredsForSPA registry entry. To do this, follow these steps:
    1. Start Registry Editor.
      • In Windows Vista, click Start
        Collapse this imageExpand this image
        the Start button
        , type regedit in the Start Search box, and then press ENTER.

        Collapse this imageExpand this image
        User Account Control
        If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
      • In Windows XP, click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\InternetMail
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type AlwaysUseCachedCredsForSPA, and then press ENTER.
    5. Right-click AlwaysUseCachedCredsForSPA, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Exit Registry Editor.

WORKAROUND

To work around this problem, follow these steps:
  1. In the Add New E-mail Account dialog box, click Test Account Settings, and enter your credentials when you are prompted.
  2. Click to select the Remember password check box, and then type your password in the Password box.
After you apply this workaround, you are not prompted for your credentials when you test the account settings or when you start Outlook.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Office Outlook 2007
Keywords: 
kbexpertiseinter kbqfe kbsurveynew kbprb KB970071
 

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