A query takes a long time to complete and increases CPU usage to a high level on the domain controllers that are running Windows Server 2003 when you use NSPI API functions to query address book information

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Article ID: 972122 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You have high number of address book and global address lists objects stored in the Active Directory in a Windows Server 2003 domain.
  • Users in the domain query address book information by using Name Service Provider Interface (NSPI) API functions.
In this scenario, the query operation takes a long time (longer than 1 minute) to complete or fails with a time out error. At the same time, the Lsass.exe process increases CPU usage to a high level on the domain controllers that are running Windows Server 2003. Therefore, domain controllers that are running Windows Server 2003 stop responding for a while.

Note Note This issue may occur in a large scale deployment of Microsoft Solution for Hosted Messaging and Collaboration (HMC).

CAUSE

The NSPI library sorts address book information on the domain controller when NSPI API functions request address book information. However, if there are many address book objects, it takes the domain controller a long time to sort the query results. Therefore, there is a slow query response on the client. Additionally, there is a CPU usage spike for the Lsass.exe process on the domain controller.

RESOLUTION

To resolve this issue, install this hotfix. This hotfix introduces NSPI caching. When a client requests address book information via NSPI the server will cache the results so subsequent requests can be serviced from the cache.

To activate the NSPI caching, run the following command to create a new registry entry under subkey 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NTDS\Parameters
:
REG ADD "HKLM\System\CurrentControlSet\Services\NTDS\Parameters" /v "Cache NSPI Hierarchy Sort" /t REG_DWORD /d 1 /f
Note The new registry entry is Cache NSPI Hierarchy Sort. It has a REG_DWORD value of 1.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntdsa.dll5.2.3790.46841,529,34424-Mar-201017:37x86
For all supported Itanium-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.46844,289,53624-Mar-201015:14IA-64SP2SP2QFE
Wntdsa.dll5.2.3790.46841,529,34424-Mar-201015:14x86SP2WOW
For all supported x64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.46842,977,28024-Mar-201015:14x64SP2Not applicable
Wntdsa.dll5.2.3790.46841,529,34424-Mar-201015:15x86SP2WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Name Service Provider Interface (NSPI), visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/cc463882.aspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 972122 - Last Review: October 7, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB972122

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