When you resume a computer that is running Windows 7, WWAN devices do not automatically connect to the target 3G network

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Article ID: 975851 - View products that this article applies to.
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SYMPTOMS

You have a computer that is running Windows 7. The computer has a wireless wide-area network (WWAN) device that connects to a 3G network. When you resume the computer from sleep or from hibernation, the WWAN device cannot automatically connect to the 3G network.

CAUSE

When you put the computer to sleep or into hibernation, the system does not remove the WWAN device until you resume the computer. This is not the expected behavior. When you resume the computer, the system also emulates the WWAN device. This race condition causes the problem.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wwanprotdim.dll8.1.7600.2060540,96029-Dec-200907:11x86
Wwansvc.dll8.1.2.0185,85614-Jul-200901:16x86
For all supported x64-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wwanprotdim.dll8.1.7600.2060548,64029-Dec-200907:55x64
Wwansvc.dll8.1.2.0229,88814-Jul-200901:41x64

WORKAROUND

To work around this problem, use one of the following methods.

Method 1

Restart the computer.

Method 2

Restart the WWAN AutoConfig service. To do this, follow these steps:
  1. Click Start, type Services in the search box, and then click Services.
  2. In the Services snap-in, right-click the WWAN AutoConfig service, and then click Restart.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 975851 - Last Review: January 13, 2010 - Revision: 1.0
APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbfix kbqfe kbexpertiseadvanced kbsurveynew kbhotfixserver KB975851

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