Article ID: 912663 - Last Review: October 31, 2007 - Revision: 4.5

Windows Live OneCare indicates that signatures for the antivirus program are out of date, and the icon on the taskbar is red

Important This article contains information that shows you how to work around a specific problem. The workaround may lower security settings or turn off security features on a computer. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect the computer.

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SYMPTOMS

You notice that the Microsoft Windows Live OneCare icon in the notification area at the far right of the taskbar has turned red. Additionally, Windows OneCare displays an action item that indicates that signatures for the antivirus program are out of date.

Note When there is an action that you must perform, Windows Live OneCare displays an Action to Take item at the top of the Windows Live OneCare main screen. Each Action to Take item contains a description of the associated issue. Each item also contains a button or a link that you must click to perform the action or to learn more about the issue.

CAUSE

This issue can occur when an update has not been downloaded correctly because of a problem with the Background Intelligent Transfer Service (BITS). BITS is a service that transfers data by using leftover bandwidth. For example, if you are currently using 60 percent of the bandwidth, BITS will use the remaining 40 percent. If the network connection is interrupted, BITS will continue where it left off when the network connection is reestablished.

RESOLUTION

To resolve this problem, use the following methods in the order in which they are presented.

Method 1: Make sure that BITS is running

  1. In Windows Vista, click Start
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    the Start button
    , type Services.msc in the Start Search box, and then click Services in the Programs list.

    In Windows XP, click Start, click Run, type Services.msc, and then press ENTER.
  2. In the list of services, right-click Background Intelligent Transfer Service, and then click Properties.
  3. Next to Startup type, make sure that Manual is selected, and then click OK.
  4. Right-click Background Intelligent Transfer Service, and then click Start. If Start is unavailable and Stop and Restart are available, the service is already started.
  5. Try to update Windows Live OneCare again.
  6. In the main OneCare window, click Check for updates under Protection Plus.

Method 2: Repair the BITS registry information

  1. In Windows Vista, click Start
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    the Start button
    , type Services.msc in the Start Search box, and then click Services in the Programs list.

    In Windows XP, click Start, click Run, type Services.msc, and then press ENTER.
  2. Type reg add hklm\system\currentcontrolset\control\backuprestore\filesnottobackup, and then click OK. A black window will quickly flash on the screen.
  3. Restart the computer.
  4. Try to update Windows Live OneCare again.
  5. In the main OneCare window, click Check for updates under Protection Plus.
Notes
  • You may want to copy the command from step 1 to the Run dialog box or the Start Search box instead of manually typing the command.
  • If the User Account Control dialog box appears and prompts you for permission to continue while you are performing an action in Windows Vista, click Continue.

Method 3: Register the DLL files in Windows XP

  1. Click Start, click Run, and then type the following commands. Press ENTER after each command:
    • regsvr32 oleaut32.dll
    • regsvr32 vbscript.dll
    • regsvr32 msxml.dll
    • regsvr32 softpub.dll
    • regsvr32 wintrust.dll
    • regsvr32 initpki.dll
    • regsvr32 cryptdlg.dll
  2. Try to update Windows Live OneCare again.
  3. In the main OneCare window, click Check for updates under Protection Plus.

Method 4: Reinstall BITS in Windows XP

Important You must have Windows XP with Service Pack 2 (SP2) installed to complete these steps.
  1. Click Start, click Run, type c:\windows\inf, and then click OK.
  2. On the Tools menu, click Folder Options.
  3. On the View tab, click to clear the Hide extensions for known file types check box, and then click OK.
  4. Right-click qmgr.inf, and then click Install.
  5. If you are prompted to insert the Service Pack 2 CD, click Browse, and then locate the %windir%\ServicePackFiles\i386 folder. Click Qmgr.dll, click Open, and then click OK.
  6. Restart the computer.
  7. Try to update Windows Live OneCare again.
  8. In the main OneCare window, click Check for updates under Protection Plus.

Method 5: Uninstall third-party Internet firewall, antispyware, and antivirus programs

Warning This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.
  1. In Windows Vista, click Start
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    the Start button
    , type appwiz.cpl in the Start Search box, and then press ENTER.

    In Windows XP, click Start, click Run, type appwiz.cpl in the Open box, and then press ENTER.
  2. In the list of installed programs, locate and uninstall any third-party firewall, antispyware, or antivirus programs.
    Note An antivirus program is designed to help protect your computer from viruses. When your antivirus program is disabled, you must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments.
    For more information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:
    129972  (http://support.microsoft.com/kb/129972/ ) Computer viruses: description, prevention, and recovery
  3. Restart the computer.
    Note After you uninstall a third-party antivirus program, contact the manufacturer of the program or visit their Web site to see whether a cleanup tool is available to help you remove any remaining files.
  4. Try to update Windows Live OneCare again.
  5. In the main OneCare window, click Check for updates under Protection Plus.
  • Windows Defender is an antispyware program that is integrated with Windows Live OneCare. We recommend that you remove Windows Defender before you install Windows Live OneCare.
  • Windows Firewall helps protect your computer after you remove other firewall or antivirus programs and until you install Windows Live OneCare. To avoid firewall conflicts, Windows Live OneCare disables Windows Firewall in Windows XP during installation.
  • If you use another antispyware program together with Windows Live OneCare, we recommend that you turn off real-time scanning in the other program. For more information, see the program documentation.
  • If your antivirus program is disabled or if you do not have an antivirus program installed, do not download or open files from sources that you do not trust, do not visit Web sites that you do not trust, and do not open e-mail attachments.


APPLIES TO
  • Windows Live OneCare
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