Internetfirewalls können das Browsen und die Dateifreigabe verhindern

Das Aktivieren einer Firewall kann verhindern, dass Sie Dateien suchen oder für andere Computer in einem Heimnetzwerk freigeben können.

Gilt für: Windows 10 (alle Editionen), Windows Server 2012 R2
Ursprüngliche KB-Nummer: 298804

Symptome

Nachdem Sie eine Internetfirewall aktiviert haben, können Sie möglicherweise nicht mehr nach anderen Computern in Ihrem Heim- oder Büronetzwerk suchen oder suchen. Außerdem können Sie möglicherweise keine Dateien für andere Computer in Ihrem Heim- oder Büronetzwerk freigeben. Wenn Sie beispielsweise das Feature Internet Connection Firewall (ICF) in Windows XP aktivieren, stellen Sie fest, dass Sie Ihr Netzwerk nicht mithilfe von "Mein Netzwerk" Places durchsuchen können. Wenn Sie den Befehl zum Anzeigen von net view \\computername Freigaben auf einem Computer in Ihrem Heim- oder Büronetzwerk verwenden, wird möglicherweise die folgende Fehlermeldung angezeigt:

Systemfehler 6118 ist aufgetreten. Die Liste der Server für diese Arbeitsgruppe ist derzeit nicht verfügbar.

Ursache

Dieses Verhalten kann auftreten, wenn Sie eine Firewall für die Netzwerkverbindung aktivieren, die Sie für Ihr Heim- oder Büronetzwerk verwenden. Standardmäßig schließt eine Firewall die Ports, die für die Datei- und Druckfreigabe verwendet werden. Der Zweck besteht darin, zu verhindern, dass Internetcomputer eine Verbindung mit Datei- und Druckfreigaben auf Ihrem Computer herstellen.

Lösung

Um dieses Verhalten zu beheben, verwenden Sie eine Firewall nur für Netzwerkverbindungen, die Sie verwenden, um eine direkte Verbindung mit dem Internet herzustellen. Verwenden Sie beispielsweise eine Firewall auf einem einzelnen Computer, der direkt über ein Kabelmodem, ein DSL-Modem oder ein DFÜ-Modem mit dem Internet verbunden ist. Wenn Sie dieselbe Netzwerkverbindung verwenden, um sowohl eine Verbindung mit dem Internet als auch mit einem Heim- oder Büronetzwerk herzustellen, verwenden Sie einen Router oder eine Firewall, die verhindert, dass Internetcomputer eine Verbindung mit den freigegebenen Ressourcen auf den Heim- oder Bürocomputern herstellen.

Verwenden Sie keine Firewall für Netzwerkverbindungen, die Sie zum Herstellen einer Verbindung mit Ihrem Heim- oder Büronetzwerk verwenden, es sei denn, die Firewall kann so konfiguriert werden, dass ports nur für Ihr Heim- oder Büronetzwerk geöffnet werden. Wenn Sie über Ihr Heim- oder Büronetzwerk eine Verbindung mit dem Internet herstellen, kann eine Firewall nur auf dem Computer oder dem anderen Gerät, z. B. einem Router, verwendet werden, der die Verbindung mit dem Internet bereitstellt. Wenn Sie beispielsweise über ein von Ihnen verwaltetes Netzwerk eine Verbindung mit dem Internet herstellen und dieses Netzwerk die Verbindungsfreigabe verwendet, um den Internetzugriff auf mehrere Computer zu ermöglichen, können Sie eine Firewall nur für die gemeinsam genutzte Internetverbindung installieren oder aktivieren. Wenn Sie über ein Netzwerk, das Sie nicht verwalten, eine Verbindung mit dem Internet herstellen, überprüfen Sie, ob Ihr Netzwerkadministrator eine Firewall verwendet.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Weitere Informationen

Eine Firewall ist Software oder Hardware, die eine Schutzbarriere zwischen Ihrem Computer und potenziell schädlichen Inhalten im Internet schafft. Es hilft, Ihren Computer vor böswilligen Benutzern und vor vielen Computerviren und Würmern zu schützen.

Wichtig

Wenn Sie eine Firewall einrichten, um Computerports zu schützen, die mit dem Internet verbunden sind, wird davon abgeraten, diese Ports zu öffnen, da sie für andere Computer im Internet verfügbar gemacht werden können. Darüber hinaus kann bestimmten Computern kein Zugriff auf die offenen Ports gewährt werden.

Die folgenden Ports sind der Dateifreigabe und der SMB-Kommunikation (Server Message Block) zugeordnet:

  • Microsoft File Sharing SMB: UDP-Ports (User Datagram Protocol) von 135 bis 139 und TCP-Ports (Transmission Control Protocol) von 135 bis 139.
  • Direkt gehosteter SMB-Datenverkehr ohne ein grundlegendes Netzwerkein-/Ausgabesystem (NetBIOS): Port 445 (TCP und UDP).

Technischer Support für Windows x64-Editionen

Ihr Hardwarehersteller bietet technischen Support und Unterstützung für Microsoft Windows x64-Editionen. Ihr Hardwarehersteller bietet Unterstützung, da eine Windows x64-Edition in Ihrer Hardware enthalten war. Ihr Hardwarehersteller hat die Installation der Windows x64 Edition möglicherweise mit eindeutigen Komponenten angepasst. Dazu gehören beispielsweise bestimmte Gerätetreiber oder optionale Einstellungen zur Leistungsoptimierung der Hardware. Wenn Sie technische Hilfe zu Ihrer Windows x64-Edition benötigen, bietet Microsoft angemessene Unterstützung. Sie müssen sich jedoch möglicherweise direkt an den Hersteller wenden. Der Hersteller kann Ihnen den besten Support für die von ihm auf der Hardware installierte Software bieten.

Weitere Informationen finden Sie unter Schützen meines PCs vor Viren.