The SMS_Executive service process for Systems Management Server 2003 stops repeatedly

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Article ID: 942212 - View products that this article applies to.
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SYMPTOMS

The SMS_Executive service (Smsexec.exe) process for Microsoft Systems Management Server (SMS) 2003 stops repeatedly. Additionally, a Crash.log file is generated in the following folder:
%SystemDrive%\SMS\Logs
The Crash.log file contains a message that resembles the following:
Time = Date_Time
Service name = SMS_EXECUTIVE
Thread name = SMS_COLLECTION_EVALUATOR
Executable = Path\smsexec.exe
Process ID = ID_number
Thread ID = ID_number
Instruction address = Memory_address
Exception = e06d7363 (Unknown exception code)
Description = ""
Raised inside CService mutex = No
CService mutex description = ""
Before the Smsexec.exe service process stops, the process consumes lot of memory.

CAUSE

This problem occurs because of a memory leak in the Smsexec.exe process.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Microsoft Systems Management Server 2003 Service Pack 2
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File nameFile versionFile sizeDateTimePlatform
Basesvr.dll2.50.4160.21371,769,47228-Feb-200623:00x86
Baseutil.dll2.50.4160.2137614,40028-Feb-200623:00x86
Distmgr.dll2.50.4160.2138421,88828-Feb-200623:05x86
Microsoft Systems Management Server 2003 Service Pack 3
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Basesvr.dll2.50.4253.31021,769,47231-Jul-200717:05x86
Baseutil.dll2.50.4253.3102614,40031-Jul-200717:05x86
Distmgr.dll2.50.4253.3109421,88831-Jul-200717:40x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 942212 - Last Review: December 17, 2007 - Revision: 2.1
APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB942212

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