A Remote Assistance session fails when the /3GB switch is enabled in the Boot.ini file on a Windows XP-based computer

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Article ID: 942432 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You are running a Windows XP-based computer.
  • You invite an expert computer to access your computer by using Remote Assistance.
In this scenario, the Remote Assistance session may fail. Therefore, you have to restart the computer and then start the Remote Assistance session again.

This issue occurs if the /3GB switch is enabled in the Boot.ini file when you start the computer.

CAUSE

If Windows XP starts when the /3GB switch is enabled, the desktop heap is only half the standard size.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Rdpdd.dll5.1.2600.321492,42413-Sep-200715:02x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 942432 - Last Review: December 26, 2007 - Revision: 1.1
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB942432

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