When client computers try to access resources on a Windows Server 2003-based file server, the Server service on the file server may stop responding

Article translations Article translations
Article ID: 942835 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When client computers try to access file resources on a Windows Server 2003-based file server, the Server service on the file server may stop responding. In this scenario, client users cannot access the shared resources on the file server. To recover from this problem, you must restart the file server.

This problem may occur if the client computers are running one of the following installations:
  • Windows Server 2003 with Service Pack 1
  • Windows Server 2003 with Service Pack 2
  • Windows Vista

CAUSE

Windows Server 2003 Service Pack 1 introduces a change to the CopyFile function. This change may cause a deadlock between the Server service and NTFS opportunistic locks (oplocks).

RESOLUTION

To resolve this problem, apply the following hotfix on the file server.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntfs.sys5.2.3790.3125592,38422-Apr-200810:29x86SP1
Ntkrnlmp.exe5.2.3790.31252,466,30422-Apr-200810:29Not ApplicableSP1
Ntkrnlpa.exe5.2.3790.31252,279,42422-Apr-200809:51x86SP1
Ntkrpamp.exe5.2.3790.31252,319,36023-Apr-200806:58Not ApplicableSP1
Ntoskrnl.exe5.2.3790.31252,426,36822-Apr-200810:29x86SP1
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntfs.sys5.2.3790.4277591,36022-Apr-200810:37x86SP2
Ntkrnlmp.exe5.2.3790.42772,496,00022-Apr-200810:37Not ApplicableSP2
Ntkrnlpa.exe5.2.3790.42772,307,58422-Apr-200809:34x86SP2
Ntkrpamp.exe5.2.3790.42772,348,54422-Apr-200809:34Not ApplicableSP2
Ntoskrnl.exe5.2.3790.42772,455,55222-Apr-200810:37x86SP2
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.31251,636,35223-Apr-200807:03IA-64SP1Not Applicable
Ntfs.sys5.2.3790.31251,886,20823-Apr-200807:03IA-64SP1Not Applicable
Ntkrnlmp.exe5.2.3790.31256,534,65623-Apr-200807:03IA-64SP1Not Applicable
Wntdll.dll5.2.3790.3125765,95223-Apr-200807:04x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.42771,636,86423-Apr-200807:30IA-64SP2Not Applicable
Ntfs.sys5.2.3790.42771,887,74423-Apr-200807:30IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.42776,569,47223-Apr-200807:30IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4277766,46423-Apr-200807:30x86SP2WOW
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.3125280,06423-Apr-200807:04x64SP1
Ntfs.sys5.2.3790.31251,127,42423-Apr-200807:04x64SP1
Ntkrnlmp.exe5.2.3790.31254,646,40023-Apr-200807:04x64SP1
Ntoskrnl.exe5.2.3790.31254,503,04023-Apr-200807:05x64SP1
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4277280,06423-Apr-200807:32x64SP2
Ntfs.sys5.2.3790.42771,044,48023-Apr-200807:32x64SP2
Ntkrnlmp.exe5.2.3790.42774,604,41623-Apr-200807:32x64SP2
Ntoskrnl.exe5.2.3790.42774,534,27223-Apr-200807:33x64SP2
Windows XP x64 Edition with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.3125280,06423-Apr-200807:04x64SP1
Ntfs.sys5.2.3790.31251,127,42423-Apr-200807:04x64SP1
Ntkrnlmp.exe5.2.3790.31254,646,40023-Apr-200807:04x64SP1
Ntoskrnl.exe5.2.3790.31254,503,04023-Apr-200807:05x64SP1
Windows XP x64 Edition with Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4277280,06423-Apr-200807:32x64SP2
Ntfs.sys5.2.3790.42771,044,48023-Apr-200807:32x64SP2
Ntkrnlmp.exe5.2.3790.42774,604,41623-Apr-200807:32x64SP2
Ntoskrnl.exe5.2.3790.42774,534,27223-Apr-200807:33x64SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Properties

Article ID: 942835 - Last Review: May 23, 2008 - Revision: 1.1
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB942835

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com