On a Windows Server 2003 R2-based computer, the Quota function of the File Server Resource Manager (FSRM) may report incorrect disk usage when both the Quota function and the shadow copies are configured on the same volume

Article translations Article translations
Article ID: 944830 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • On a Windows Server 2003 R2-based computer, you create a Quota function to manage disk usage on a volume in the File Server Resource Manager (FSRM).
  • You enable the Shadow Copies feature on the volume.

    Note When you enable the Shadow Copies feature on the volume, a shadow copy is created on this volume.
In this scenario, the Quota function can correctly report the disk usage. However, if multiple shadow copies are created on this volume, the Quota function incorrectly reports the disk usage.

For example, when the first shadow copy is created, FSRM correctly reports that 300 MB of disk space is used. When the second shadow copy is created, the actual used disk space is more than 300 MB. However, FSRM reports that only 600 MB disk of space is used for these two shadow copies.

Additionally, when this problem occurs, the following information may be logged in the event log:
Event Type:	Warning
Event Source:	SRMSVC
Event Category:	None
Event ID:	12325
Date:		<Date>
Time:		<Time>
User:		N/A
Computer:	<Computer Name>
Description:
The 120% quota threshold for quota on E:\ on server <server name> has been exceeded. The quota limit is <number> MB and the current usage is <number> MB (120% of limit).

CAUSE

This problem occurs because the Quota.sys filter driver incorrectly calculates disk space that is used by shadow copies when both Quota function and shadow copies are configured on the same volume.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 R2 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4201590,33611-Dec-200701:06x86
Windows Server 2003 with Service Pack 2, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.42011,044,48011-Dec-200703:29x64
Note To view the correct disk usage report, you must re-create all affected quotas after you install this hotfix.

WORKAROUND

To work around this problem, store the shadow copies on another disk.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 944830 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbbug kbfix kbHotfixServer kbqfe KB944830

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com