The preview function does not work correctly in Windows Movie Maker on a Windows Vista-based computer

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Article ID: 945125 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You are using a Windows Vista-based computer that is running software graphics drivers for certain Intel chipsets.
  • You import some .wmv video files into the content pane of Windows Movie Maker on the computer.
  • You convert these .wmv video files to .avi video files by using Windows Movie Maker.
  • You add some .avi video files in the Storeboard area of Windows Movie Maker.
  • You drag a transition template into the Storeboard area.
In this scenario, the Storeboard area cannot be displayed. Additionally, if you click Play to preview the video, the preview function does not work.

Note If you remove the transition template from the Storeboard area, the Storeboard area is displayed correctly.

CAUSE

This issue occurs because of a floating-point precision problem in the Direct3D program. The precision problem is caused by the D3DCREATE_FPU_PRESERVE flag.

This issue typically occurs on computers that are running the following chipsets:
  • Intel G35 Express Chipset
  • Intel Q35 Express Chipset
  • Intel Q33 Express Chipset
  • Intel G33 Express Chipset
  • Intel G31 Express Chipset
  • Intel Q965 Express Chipset
  • Intel Q963 Express Chipset
  • Intel G965 Express Chipset
  • Intel 946GZ Express Chipset
  • Intel 945G Express Chipset
  • Intel 945GT Express Chipset
  • Intel 945GC Express Chipset
  • Intel 945GZ Express Chipset Mobile
  • Intel GM965 Express Chipset Mobile
  • Intel 945GM Express Chipset Mobile
  • Intel 945GMS Express Chipset Mobile
  • Intel GL960 Express Chipset Mobile
  • Intel 943GML Express Chipset Mobile
  • Intel 940GML Express Chipset Mobile
  • Intel 945GU Express Chipset

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfixes and security updates that are included in SP2 for Windows Vista Service and for Windows Server 2008

For more information about the hotfixes and the security updates that are included in SP2 for Windows Vista and for Windows Server 2008, visit the following Microsoft TechNet Web site: -
http://technet.microsoft.com/en-us/library/dd335033.aspx
Note: Currently, the list of hotfixes and security updates is available only in English.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
:
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_a766689f415b2b5ac91130e4df20c029_31bf3856ad364e35_6.0.6000.20722_none_8385c5e65c845cd7.manifestNot Applicable70216-Nov-200717:14Not Applicable
Amd64_microsoft-windows-moviemaker_31bf3856ad364e35_6.0.6000.20722_none_4d1046a4e1809177.manifestNot Applicable40,24316-Nov-200717:20Not Applicable
Filters.xmlNot Applicable14,07607-Jan-200706:05Not Applicable
Moviemaker-ppdlic.xrm-msNot Applicable2,96916-Nov-200704:38Not Applicable
Moviemk.dll6.0.6000.2072216,354,81616-Nov-200705:07x64
Moviemk.exe6.0.6000.20722150,52816-Nov-200703:12x64
News.pngNot Applicable138,66007-Jan-200706:05Not Applicable
Paint.pngNot Applicable67,21307-Jan-200706:05Not Applicable
Sample1.jpgNot Applicable83,92907-Jan-200706:05Not Applicable
Sample2.jpgNot Applicable123,13507-Jan-200706:05Not Applicable
Sample3.jpgNot Applicable129,31207-Jan-200706:05Not Applicable
Sample4.jpgNot Applicable161,51407-Jan-200706:05Not Applicable
Wmm2ae.dll6.0.6000.20722336,38416-Nov-200705:08x64
Wmm2ext.dll6.0.6000.207
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Filters.xmlNot Applicable14,07607-Jan-200706:05Not Applicable
Moviemaker-ppdlic.xrm-msNot Applicable2,96916-Nov-200704:38Not Applicable
Moviemk.dll6.0.6000.2072216,354,81616-Nov-200705:07x64
Moviemk.exe6.0.6000.20722150,52816-Nov-200703:12x64
News.pngNot Applicable138,66007-Jan-200706:05Not Applicable
Paint.pngNot Applicable67,21307-Jan-200706:05Not Applicable
Sample1.jpgNot Applicable83,92907-Jan-200706:05Not Applicable
Sample2.jpgNot Applicable123,13507-Jan-200706:05Not Applicable
Sample3.jpgNot Applicable129,31207-Jan-200706:05Not Applicable
Sample4.jpgNot Applicable161,51407-Jan-200706:05Not Applicable
Wmm2ae.dll6.0.6000.20722336,38416-Nov-200705:08x64
Wmm2ext.dll6.0.6000.2072226,62416-Nov-200705:08x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Windows Movie Maker in Windows Vista, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/Help/ec3fff68-e53c-4168-ae74-8557325e57e21033.mspx
If you do not specify the D3DCREATE_FPU_PRESERVE flag, the Direct3D program uses "single-precision, round-to-nearest mode" for the following reasons:
  • Double precision mode reduces the performance of the Direct3D program.
  • Parts of the Direct3D program assume that floating-point unit exceptions are masked. Unmasking these exceptions may cause unpredictable behavior.
For more information about the D3DCREATE_FPU_PRESERVE flag, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/bb172527.aspx
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 945125 - Last Review: December 7, 2007 - Revision: 2.3
APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbexpertisebeginner kbhotfixserver kbqfe KB945125

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