After you are prompted to upgrade the DRM components on a Windows Vista-based computer, Windows Media Center cannot perform a security upgrade

Article translations Article translations
Article ID: 945612 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You are running a Windows Vista-based computer.
  • You try to play Digital Rights Management (DRM)-protected content in a hosted HTML application.
In this scenario, you may receive the following message:
Security Upgrade Required
The owner of the protected content you are trying to access requires you to first upgrade some of the Microsoft digital rights management (DRM) components on your computer.
Click OK to upgrade your DRM components.
If you click OK, Windows Media Center starts the security upgrade process. However, the upgrade process may never move on to next page as expected. Additionally, the pointer remains in a busy state during the upgrade process.

When this problem occurs, a 0xc00d277e error code or a 0xc00d277d error code is logged in the IndivlastHR registry entry. For more information about this registry entry, see the "The IndivlastHR registry entry" section.

CAUSE

This issue occurs because of an error in Windows Media Center. This error occurs when Windows Media Center handles the DRM security upgrade (DRM individualization) through a slow or latent network connection.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfixes and security updates that are included in SP2 for Windows Vista Service and for Windows Server 2008

For more information about the hotfixes and the security updates that are included in SP2 for Windows Vista and for Windows Server 2008, visit the following Microsoft TechNet Web site: -
http://technet.microsoft.com/en-us/library/dd335033.aspx
Note: Currently, the list of hotfixes and security updates is available only in English.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msil_ehexthost_31bf3856ad364e35_6.0.6000.20728_none_bd7e7601dad7e2db.manifestNot applicable12,69428-Nov-200715:29Not applicable
Msil_ehshell_31bf3856ad364e35_6.0.6000.20728_none_8a2c148c5d9c0de2.manifestNot applicable8,36028-Nov-200715:29Not applicable
Msil_microsoft.mediacenter.shell_31bf3856ad364e35_6.0.6000.20728_none_4f29b843b1e08478.manifestNot applicable3,37428-Nov-200715:29Not applicable
Msil_microsoft.mediacenter.ui_31bf3856ad364e35_6.0.6000.20728_none_31b806f373348192.manifestNot applicable3,36528-Nov-200715:29Not applicable
Msil_microsoft.mediacenter_31bf3856ad364e35_6.0.6000.20728_none_24135fe6e84ceda8.manifestNot applicable4,22828-Nov-200715:29Not applicable
Update.mumNot applicable3,48028-Nov-200715:29Not applicable
X86_db04fde6a902790fac8fdd7b38d5660e_31bf3856ad364e35_6.0.6000.20728_none_d2bdc25ca34eccd3.manifestNot applicable2,36428-Nov-200715:29Not applicable
X86_e1fc85461e7007e40ba02ab5c6203051_31bf3856ad364e35_6.0.6000.20728_none_1a975bce33776a86.manifestNot applicable69928-Nov-200715:29Not applicable
X86_microsoft-windows-ehome-ehres_31bf3856ad364e35_6.0.6000.20728_none_50a1c4926c783d8f.manifestNot applicable3,11828-Nov-200715:29Not applicable
X86_microsoft-windows-ehome-ehuihlp_31bf3856ad364e35_6.0.6000.20728_none_3aa0cf1f473d884b.manifestNot applicable11,12228-Nov-200715:29Not applicable
Ehexthost.exe6.0.6000.20728135,16828-Nov-200707:17x86
Ehexthost.exe.configNot applicable80628-Nov-200703:06Not applicable
Ehshell.dll6.0.6000.207284,382,72028-Nov-200707:17x86
Microsoft.mediacenter.shell.dll6.0.6000.207281,269,76028-Nov-200707:18x86
Microsoft.mediacenter.ui.dll6.0.6000.207282,351,10428-Nov-200707:18x86
Microsoft.mediacenter.dll6.0.6000.20728217,08828-Nov-200707:18x86
Ehres.dll6.0.6000.2072810,103,80828-Nov-200707:14x86
Ehuihlp.dll6.0.6000.207281,498,11228-Nov-200707:14x86
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_45001b47be575c3f0efe6685dbeaa096_31bf3856ad364e35_6.0.6000.20728_none_f1ea92e6a3c14626.manifestNot applicable70328-Nov-200715:29Not applicable
Amd64_c66437ceb97dd320a8f1ff75088377fe_31bf3856ad364e35_6.0.6000.20728_none_cb2f90cfd80f2df2.manifestNot applicable3,04028-Nov-200715:29Not applicable
Amd64_microsoft-windows-ehome-ehres_31bf3856ad364e35_6.0.6000.20728_none_acc0601624d5aec5.manifestNot applicable3,12228-Nov-200715:33Not applicable
Amd64_microsoft-windows-ehome-ehuihlp_31bf3856ad364e35_6.0.6000.20728_none_96bf6aa2ff9af981.manifestNot applicable11,17428-Nov-200715:33Not applicable
Msil_ehexthost_31bf3856ad364e35_6.0.6000.20728_none_bd7e7601dad7e2db.manifestNot applicable12,69628-Nov-200715:33Not applicable
Msil_ehshell_31bf3856ad364e35_6.0.6000.20728_none_8a2c148c5d9c0de2.manifestNot applicable8,36028-Nov-200715:33Not applicable
Msil_microsoft.mediacenter.shell_31bf3856ad364e35_6.0.6000.20728_none_4f29b843b1e08478.manifestNot applicable3,37428-Nov-200715:33Not applicable
Msil_microsoft.mediacenter.ui_31bf3856ad364e35_6.0.6000.20728_none_31b806f373348192.manifestNot applicable3,36528-Nov-200715:33Not applicable
Msil_microsoft.mediacenter_31bf3856ad364e35_6.0.6000.20728_none_24135fe6e84ceda8.manifestNot applicable4,22828-Nov-200715:33Not applicable
Update.mumNot applicable3,93628-Nov-200715:29Not applicable
Wow64_microsoft-windows-ehome-ehuihlp_31bf3856ad364e35_6.0.6000.20728_none_a11414f533fbbb7c.manifestNot applicable2,74728-Nov-200715:33Not applicable
Ehres.dll6.0.6000.2072810,104,32028-Nov-200708:09x64
Ehuihlp.dll6.0.6000.207281,585,66428-Nov-200708:09x64
Ehexthost.exe6.0.6000.20728135,16828-Nov-200708:13x86
Ehexthost.exe.configNot applicable80628-Nov-200703:03Not applicable
Ehshell.dll6.0.6000.207284,382,72028-Nov-200707:17x86
Microsoft.mediacenter.shell.dll6.0.6000.207281,269,76028-Nov-200707:18x86
Microsoft.mediacenter.ui.dll6.0.6000.207282,351,10428-Nov-200707:18x86
Microsoft.mediacenter.dll6.0.6000.20728217,08828-Nov-200707:18x86
Ehuihlp.dll6.0.6000.207281,498,11228-Nov-200707:14x86

WORKAROUND

To work around this problem, use one of the following methods.

Method 1

Play back the DRM-protected content by using Windows Media Player directly.

Method 2

Perform the DRM security upgrade by visiting the following Microsoft Web site:
http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The IndivlastHR registry entry

When this problem occurs, the IndivlastHR registry entry is automatically generated. To view this registry entry, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    Collapse this imageExpand this image
    Security shield
    If you are prompted for the administrator password or for confirmation, type the password, or click Continue.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\DRM
  3. In the details pane, double-click IndivlastHR to check the error code that is logged in the Value data box.
  4. Exit Registry Editor.
For more information about DRM individualization, visit the following Microsoft Web sites:
http://msdn2.microsoft.com/en-us/library/aa385160.aspx
http://msdn2.microsoft.com/en-us/library/ms867216.aspx
hhttp://www.microsoft.com/windows/windowsmedia/forpros/drm/faq.aspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 945612 - Last Review: December 20, 2007 - Revision: 1.4
APPLIES TO
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbfix kbexpertisebeginner kbqfe kbhotfixserver KB945612

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com