Help and Support
 

powered byLive Search

FIX: The Web recorder may miss a request or may miss some parameters when you use a Web recorder to record Web tests in Visual Studio 2008 Team System Test Edition

Article ID:946673
Last Review:June 3, 2008
Revision:1.0
On This Page

SYMPTOMS

Consider the following scenario. In Microsoft Visual Studio 2008 Team System Test Edition, you use a Web recorder to record Web tests. A request does not define a content type. The request is redirected. In this scenario, you may experience one of the following symptoms.
The Web recorder may miss the request.
The Web recorder may miss some parameters that are passed to the request. This occurs if the content type of the request is Post.

Back to the top

CAUSE

This problem occurs because the Web recorder ignores requests that do not have a content type inside the header. Therefore, the requests are not added to the test.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Visual Studio 2008 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Visual Studio 2008 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.visualstudio.qualitytools.loadtestui.dll9.0.21022.611,708,03218-Mar-200812:53x86
Microsoft.visualstudio.qualitytools.recorderbar.dll9.0.21022.6115155218-Mar-200812:53x86

Back to the top

WORKAROUND

To work around these problems, use the Fiddler tool to record the tests and to save the captured data as Visual Studio Web tests. Then, import the Web tests into Visual Studio Team System 2008 Test Edition.

To download the Fiddler tool, visit the following Microsoft Web site:
http://www.fiddlertool.com/fiddler/ (http://www.fiddlertool.com/fiddler/)

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

This hotfix resolves this problem by adding the content type of the redirected request to the initial request. For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/LN/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft Visual Studio Team System 2008 Team Suite

Back to the top

Keywords: 
kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB946673

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.