When you try to use the MSTSC command from Terminal Services Client 6.0 to connect to the local Windows XP-based computer, a black screen may appear for several minutes

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Article ID: 951163 - View products that this article applies to.
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SYMPTOMS

On a Windows XP-based computer, you have Terminal Services Client 6.0 installed. On this computer, you try to connect to the local computer by running one of the following commands:
MSTSC /V:ComputerName /CONSOLE
MSTSC /V:ComputerIPAddress /CONSOLE
When you do this, a black screen may appear for several minutes. After several minutes, the desktop and the pointer reappear on the screen. However, the keyboard is unusable.

CAUSE

The issue occurs because the getaddrinfo function cannot translate the local network interface address in Windows XP.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
6to4svc.dll5.1.2600.2975100,35216-Aug-200612:08x86SP2
Afd.sys5.1.2600.3394138,36820-Jun-200810:44x86SP2
Dnsapi.dll5.1.2600.3418147,96828-Jul-200814:24x86SP2
Mswsock.dll5.1.2600.3394245,24820-Jun-200815:49x86SP2
Tcpip.sys5.1.2600.3394360,96020-Jun-200810:44x86SP2
Tcpip6.sys5.1.2600.3394225,92020-Jun-200809:32x86SP2
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Afd.sys5.1.2600.5649138,49628-Jul-200811:44x86SP3
Dnsapi.dll5.1.2600.5649147,96828-Jul-200813:41x86SP3
Mswsock.dll5.1.2600.5649245,24828-Jul-200813:41x86SP3
Tcpip.sys5.1.2600.5649361,60028-Jul-200811:53x86SP3
Tcpip6.sys5.1.2600.5649225,85628-Jul-200810:35x86SP3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, when you try to connect to the local Windows XP-based computer, you receive the following error message:
Remote Desktop Disconnected
The client could not connect. You are already connected to the console of this computer. A new console session cannot be established.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
925876 Remote Desktop Connection (Terminal Services Client 6.0)
For more information about the getaddrinfo function, visit the following Web site:
http://msdn.microsoft.com/en-us/library/ms738520.aspx

Properties

Article ID: 951163 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbqfe KB951163

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