The installation process may stop responding when you try to install some software on a Windows XP-based computer

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Article ID: 957217 - View products that this article applies to.
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SYMPTOMS

When you try to install some software on a Windows XP-based computer, the installation process may stop responding (hang). However, the installation status shows 100 percent. The computer does not respond until you restart the system.

This problem may occur if the software is installed by using the Windows Installer service.

CAUSE

This problem occurs because of a race condition in the Windows Installer service.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 and Windows Installer 3.1 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Msi.dll3.1.4001.56622,842,62426-Aug-200807:33x86
To resolve this problem, you can also upgrade the Windows Installer service to the latest version (Windows Installer 4.5). For more information, visit the following Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=5a58b56f-60b6-4412-95b9-54d056d6f9f4&DisplayLang=en

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Windows Installer, visit the following Web site:
http://msdn.microsoft.com/en-us/library/cc185688(VS.85).aspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
893803 Windows Installer 3.1 v2 (3.1.4000.2435) is available

Properties

Article ID: 957217 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbfix kbbug kbexpertiseinter kbqfe KB957217

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