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PRB: Custom Import of a Large User List May Cause an LDAP Timeout

Article ID:195387
Last Review:October 21, 2000
Revision:1.0
This article was previously published under Q195387

SYMPTOMS

During the import of a large user list, Custom Import reports the following error message:
The import was unable to finish because of the following problem. The LDAP server may not be configured correctly. Please set the Max Query Timeout value to 0 (unlimited) and the Max ResultSet value to Unlimited.
The following error is reported in the application event log:
   Source: P&M Directory Store
   Description:
   SQL Error: HRESULT: 80040e31 Minor Code: 0 Source: Microsoft OLE DB
   Provider for ODBC Drivers Description: [Microsoft][ODBC SQL Server
   Driver]Timeout expired SQLErrorInfo: 0, S1T00
				

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CAUSE

This occurs because the SQL Server computer takes longer to respond to an LDAP query than the LDAP application allows.

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RESOLUTION

To resolve this problem, use the Site Server Administration MMC to increase the LDAP query timeout by performing the following steps:
1.Select Personalization and Membership.
2.Select the LDAP server, and expand the server entry to list the membership instances.
3.Select the membership instance, and expand it.
4.Select the LDAP service, and click Properties.
5.In the LDAP Properties page, click the Directory Properties tab.
6.Under Master databases on this partition, select the database that is listed.
7.Click the Edit button.
8.In the Database Server Properties dialog box, specify the Default Timeout parameter by increasing the value from 60 seconds to 600 seconds.
NOTE: You must perform steps 6-8 for each individual SQL database.

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STATUS

Microsoft has confirmed this to be a problem in Site Server version 3.0.

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MORE INFORMATION

Increasing the LDAP timeout should be done cautiously. This change can contribute to delays in the completion of the custom import process. In some cases it has been observed that the process can take days to complete. The timeout value should reflect a reasonable delay time. Other areas to check include the hardware that SQL Server runs on, memory on all platforms, database size, number of imported attributes, and network connection speeds.

Usage Analysis may return the following error during custom import:
0x80072022L
This error indicates that the following was returned by LDAP:
Time limit has exceeded.

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APPLIES TO
Microsoft Site Server 3.0 Standard Edition

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Keywords: 
kbpending kbprb KB195387

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