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Event ID 4096 Occurs When You Run Outlook Mobile Access for Exchange Server 5.5

Article ID:297969
Last Review:October 28, 2006
Revision:2.1
This article was previously published under Q297969
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry
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SYMPTOMS

When you browse your mailbox by using Outlook Mobile Access against an Exchange Server 5.5 computer, your session may time out on the device. In addition, the following event ID messages may be logged in the Application event log:
Event Type: Error
Event Source: Exch55DataProvider
Event Category: General
Event ID: 4096
User: N/A
Computer: MMIServer
Description:
Event Source: HrDatedItemsSummary (CATCH)
-------------
Unknown Error
Event Type: Error
Event Source: Exch55DataProvider
Event Category: General
Event ID: 4096
User: N/A
Computer: MMIServer
Description:
Event Source: Exchange55Mailbox.cpp CExchange55Mailbox::strGetItemList( )
-------------
Code = 80004005 WCode = 0000 HRESULT = 80040200
Event Type: Error
Event Source: Exch55DataProvider
Event Category: General
Event ID: 4096
User: N/A
Computer: MMIServer
Description:
Event Source: CCDO1SessionPool::objGetCDOSession
-------------
Session in use, age in milliseconds = 28641. A user who has a session established tried to open another session.
NOTE: Session age varies.

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CAUSE

This issue can occur because the timeout value for the Mobile Information Server Exchange Server 5.5 component has been exceeded. This value determines the time period that Mobile Information Server waits for a response from the Exchange Server 5.5 computer.

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RESOLUTION

To resolve this issue, increase the timeout value in the registry for the Mobile Information Server Exchange Server 5.5 component:
1.Start Registry Editor (Regedt32.exe).
2.Locate the MMIS55COMTimeout value under the following key in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\OMA55\MMIS55COMAccess
3.On the Edit menu, click DWORD, type 45, and then click OK. (See the following "Setting the Timeout Value" section in this article for more information about setting a value.)
4.Quit Registry Editor.

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Setting the Timeout Value

The default timeout value is 20 seconds. In the example in the "Symptoms" section of this article, the lookup on the Exchange Server 5.5 computer took 28.6 seconds to return (28641 milliseconds). To determine the value to enter, look at the event ID message to see how long the query took on your server before it timed out, and then add approximately 50 percent to that value, for example:
(28641ms/1000)=28.641 seconds 28.641*1.5=42.96 rounded up to 45 seconds.
If the query is taking longer than 60 seconds, check to see if the server is suffering performance problems or if there is a networking problem.

For additional information about troubleshooting Microsoft Outlook Web Access (OWA) in Exchange Server 5.5, click the article numbers below to view the articles in the Microsoft Knowledge Base:
247779 (http://support.microsoft.com/kb/247779/EN-US/) XCLN: Mailboxes Not Available Through OWA, with Server Timeout Error ASP0113

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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MORE INFORMATION

The Outlook Mobile Access for Exchange Server 5.5 component in Mobile Information Server version 1.0 uses CDO to talk to Exchange Server 5.5. This component is the same component that OWA uses to communicate with to Exchange Server 5.5.

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APPLIES TO
Microsoft Mobile Information Server 2001 Enterprise Edition

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Keywords: 
kbbug KB297969

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