Help and Support
 

powered byLive Search

FIX: A significant delay may occur when you try to debug an ASP.NET-connected application in Visual Studio 2005

Article ID:936344
Last Review:May 14, 2008
Revision:2.2
On This Page

SYMPTOMS

Consider the following scenario:
In Microsoft Visual Studio 2005, you create multiple pages in different folders in an ASP.NET-connected application.
These pages use the same name.
You set a breakpoint in one of these pages.
In this scenario, a significant delay may occur when you try to debug the ASP.NET-connected application. Additionally, this delay may cause a time-out error. In this case, you receive the following error message:
Unable to start debugging on the web server. The operation has timeout.

Back to the top

CAUSE

This problem is caused by a performance issue in the Microsoft .NET Framework 2.0 and in Visual Studio 2005.

Back to the top

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 (http://support.microsoft.com/kb/935791/) How to obtain the latest Windows Vista service pack

Back to the top

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

For more information about the MSDN Code Gallery, visit the following Microsoft Web site:
http://code.msdn.microsoft.com/KB936344 (http://code.msdn.microsoft.com/KB936344)

Prerequisites

You must have Visual Studio 2005 Service Pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Visual Studio 2005
File nameFile versionFile sizeDateTimePlatform
Vsdebug.dll8.0.50727.8801,319,42403-May-200720:45x86
The .NET Framework 2.0
File nameFile versionFile sizeDateTimePlatform
Diasymreader.dll8.0.50727.880551,93603-May-200723:34x86

Note To completely resolve this problem, you must install two separate hotfix packages. One hotfix resolves a performance issue in the Diasymreader.dll file in the .NET Framework 2.0. The other hotfix resolves an issue in the Vsdebug.dll file in Visual Studio 2005.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

Back to the top

MORE INFORMATION

To determine whether you are experiencing this problem, use one of the following methods.

Back to the top

Method 1: Disable all the breakpoints

1.Open Visual Studio 2005.
2.Open the ASP.NET-connected application.
3.On the Debug menu, click Delete All Breakpoints.
4.Determine whether performance improves.

Back to the top

Method 2: Disable the "Require source files to exactly match the original version" option

1.Open Visual Studio 2005.
2.On the Tools menu, click Options.
3.Click to select the Show all settings check box.
4.Click the Debugging node.
5.Click to clear the Require source files to exactly match the original version check box.

Note If you clear the Require source files to exactly match the original version check box, you have to use function breakpoints.
6.Determine whether performance improves.

Back to the top

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft .NET Framework 2.0
Microsoft Visual Studio 2005 Standard Edition
Microsoft Visual Studio 2005 Professional Edition
Microsoft Visual Studio 2005 Express Edition
Microsoft Visual Studio 2005 Team Edition for Software Architects
Microsoft Visual Studio 2005 Team Edition for Software Developers
Microsoft Visual Studio 2005 Team Edition for Software Testers

Back to the top

Keywords: 
kbvistasp1fix kbfix kbpubtypekc kbqfe KB936344

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.