You experience a long logon time when you try to log on to a Windows 7-based or a Windows Server 2008 R2-based client computer that uses roaming profiles

Article ID: 2728738 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You have a client computer that is running Windows 7 or Windows Server 2008 R2 in a network environment.
  • User accounts are configured to use roaming profiles when users log on to the computer from a remote site.
  • You enable the following Group Policy setting to enable slow link detection for roaming profiles:
    Computer Configuration\Administrative Templates\System\User Profiles\Slow network connection timeout for user profiles
  • You configure the Connection speed option and the Time option in the Group Policy setting.
  • You log on to the client computer from a remote site by using a network connection. The network connection has a fast link speed to the profile server and has high network latency.

    Note The high network latency causes the download speed on the computer to be slow.
In this scenario, the time that is required for you to log on to the computer is longer than expected.

Note This issue also occurs when you do not enable the Slow network connection timeout for user profiles Group Policy setting. When you do not enable the Group Policy setting, the computer uses the default settings for the Connection speed option and for the Time option.

Cause

This issue occurs because the computer ignores the Time option and therefore does not consider network latency. When the client computer detects that the link speed is fast, the computer assumes that the network connection is fast. Then, the client computer starts to download the roaming profile, and you experience a slow logon process.

Resolution

Hotfix information

Important This hotfix has been re-released to address an issue in which the digital signature on files produced and signed by Microsoft will expire prematurely, as described in Microsoft Security Advisory 2749655.

After you install the hotfix that is described in this Microsoft Knowledge Base (KB) article on the client computer, the computer considers both the Time option and the Connection Speed option in the Slow network connection timeout for user profiles Group Policy setting. You can use the Time option to adjust network latency.

When you install the hotfix that is described in this KB article on the client computer, a new DWORD value named UseSMBBasedBandwidthAndLatency that has a value of 1 is added in the following registry subkey:
\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ProfSvc\Parameters

If you do not want the computer to consider network latency, set the value of the UseSMBBasedBandwidthAndLatency registry entry to 0.


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Profsvc.dll6.1.7601.22055172,54413-Jul-201209:33x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Profsvc.dll6.1.7601.22055220,16013-Jul-201210:32x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Profsvc.dll6.1.7601.22055468,99213-Jul-201209:43IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


In the policy "Slow network connection timeout for user profiles" , the Time option has been found to be the most reliable option for measuring slow link for profiles. Using the connection speed does not always produce the desired effect due to the mechanism being dependent on SMB performance.

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot Applicable
File size1,868
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameX86_c62688eee7ad56ae27e3806e9b7c1097_31bf3856ad364e35_6.1.7601.22055_none_6bfed14fa5c6369f.manifest
File versionNot Applicable
File size695
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameX86_eab6dc965598dda3aa039321f170235a_31bf3856ad364e35_6.1.7601.22113_none_59a88d6d7a60939d.manifest
File versionNot Applicable
File size700
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameX86_microsoft-windows-profsvc_31bf3856ad364e35_6.1.7601.22055_none_fe17fc91aa2c7850.manifest
File versionNot Applicable
File size40,206
Date (UTC)16-Jul-2012
Time (UTC)07:55
PlatformNot Applicable
File nameX86_usesmbbasedbandwidthandlatency_31bf3856ad364e35_6.1.7601.22113_none_0afad33f76c363dd.manifest
File versionNot Applicable
File size859
Date (UTC)14-Sep-2012
Time (UTC)18:36
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_68b94f4ccf3c61d83558d7a3448605f8_31bf3856ad364e35_6.1.7601.22113_none_a2f8188b277b5fd2.manifest
File versionNot Applicable
File size704
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameAmd64_ee48c6ee7722cb613fc969a1ea04cbd2_31bf3856ad364e35_6.1.7601.22055_none_eb137fe9441cbeb8.manifest
File versionNot Applicable
File size699
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameAmd64_microsoft-windows-profsvc_31bf3856ad364e35_6.1.7601.22055_none_5a3698156289e986.manifest
File versionNot Applicable
File size40,210
Date (UTC)16-Jul-2012
Time (UTC)07:58
PlatformNot Applicable
File nameAmd64_usesmbbasedbandwidthandlatency_31bf3856ad364e35_6.1.7601.22113_none_67196ec32f20d513.manifest
File versionNot Applicable
File size861
Date (UTC)14-Sep-2012
Time (UTC)20:31
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,307
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_44d4cbc1969e55455ed8ac72cdcf782a_31bf3856ad364e35_6.1.7601.22113_none_d52174c0b4ba6895.manifest
File versionNot Applicable
File size702
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameIa64_cf6f059c7153682f65d27a7713a152a2_31bf3856ad364e35_6.1.7601.22055_none_385ed640026a64b1.manifest
File versionNot Applicable
File size697
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable
File nameIa64_microsoft-windows-profsvc_31bf3856ad364e35_6.1.7601.22055_none_fe19a087aa2a814c.manifest
File versionNot Applicable
File size40,208
Date (UTC)16-Jul-2012
Time (UTC)07:51
PlatformNot Applicable
File nameIa64_usesmbbasedbandwidthandlatency_31bf3856ad364e35_6.1.7601.22113_none_0afc773576c16cd9.manifest
File versionNot Applicable
File size860
Date (UTC)14-Sep-2012
Time (UTC)20:32
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,673
Date (UTC)17-Sep-2012
Time (UTC)10:07
PlatformNot Applicable

Properties

Article ID: 2728738 - Last Review: March 21, 2013 - Revision: 5.0
Applies to
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2728738

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