HOW TO: Preserve Formulas If You Save a Document As a Text File in Excel 2000

Article translations Article translations
Article ID: 213913 - View products that this article applies to.
This article was previously published under Q213913
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SUMMARY

In Microsoft Excel, you may occasionally want to save a document as a text file; for example, to fix corruption in the file.

Although an Excel file is saved as a text file, only the active sheet and the displayed values are saved. All formulas on the active sheet that are not displayed are discarded. This step-by-step article shows you to preserve those formulas that are otherwise discarded.

Preserve Formulas If You Save As Text

You can preserve the formulas when you save the file as a text file if the formulas are displayed on the active sheet.

To display formulas in cells of the active sheet, use one of the following methods.

Method 1: Keyboard

  1. Switch to the worksheet that you want.
  2. Press CTRL+ACCENT GRAVE (`).

Method 2: Options Menu

  1. On the Tools menu, click Options.
  2. Click the View tab.
  3. In the Windows options section, click to select the Formulas check box.
  4. Click OK.
After the formulas are displayed in the cells, the file can be saved as a text file. This preserves both the values and formulas. When you reopen the file, the Text Import Wizard prompts you for the original data type and for you to indicate whether the file is fixed-width or delimited. If you select delimited for the file type and select Tab as the delimiter, the formulas are placed back in their respective cells, and the values that they produce are displayed.

The only way to preserve the formulas and values that were in individual cells on the original worksheet is to open the file as a tab-delimited file. All other methods force the text file to display its formulas when the Text Import Wizard is finished.

Properties

Article ID: 213913 - Last Review: October 14, 2013 - Revision: 3.1
APPLIES TO
  • Microsoft Excel 2000 Standard Edition
Keywords: 
kbnosurvey kbarchive kbhowto kbhowtomaster KB213913

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com