You receive the Error 1904 and Error 1919 when you try to repair Office XP running on Windows NT 4.0 or Windows 98

Article translations Article translations
Article ID: 299066 - View products that this article applies to.
This article was previously published under Q299066
Expand all | Collapse all

SYMPTOMS

When you run repair on your Microsoft Office XP installation, you may receive the following error message:
Error 1904. Setup cannot register module C:\Program Files\Microsoft Office\Office\Office10\1033\Msrclr40.dll. If you click Cancel or Ignore, run Setup again and reinstall or repair your Office installation. If problem perists, contact Microsoft Product Suport Services (PSS) for assistance. For information about how to contact PSS, see C:\Program Files\Microsoft Office\Office10\1033\PSS10R.CHM.
When you click Ignore, you receive the following error messages:
Error 1919. Error configuring ODBC data source: MS Access Database. ODBC error 0: Verify that the file MS Access Database exists and that you can access it.
Error 1919. Error configuring ODBC data source: Excel Files. ODBC error 0: Verify that the file Excel Files exists and that you can access it.
Error 1919. Error configuring ODBC data source: Visual Foxpro Database. ODBC error 0: Verify that the file Visual Foxpro Database exists and that you can access it.
Error 1919. Error configuring ODBC data source: Visual Foxpro Tables. ODBC error 0: Verify that the file Visual Foxpro Tables exists and that you can access it.
Error 1919. Error configuring ODBC data source: dBASE Files. ODBC error 0: Verify that the file dBASE Files exists and that you can access it.

CAUSE

This problem can occur when you run the Office 97 File and Registry Eraser Utility (Eraser97), version 3.0 or earlier, and then do either of the following:
  • You run the Microsoft Office XP Setup program in Maintenance Mode and choose Repair Office. -or-

  • You click Detect and Repair on the Help menu of any Office program.
In this situation, the file Asycfilt.dll is removed by the Eraser97 program and is not repaired by either the Office installation or the System Files Update installation. To verify your specific version of the Office 97 File and Registry Eraser Utility, follow these steps:
  1. Click Start, point to Settings, and then click For Files or Folders.
  2. In the Search for files or folders named box, type Eraser97.exe and then click Search Now.
  3. Right-click Eraser97.exe. Click Properties on the shortcut menu, and then click the Version tab.

RESOLUTION

To resolve this problem, follow these steps:
  1. Insert your Microsoft Office XP CD-ROM in your computer's CD-ROM drive. Hold the SHIFT key to stop the Setup program from automatically starting, or click Cancel when the Setup program runs.
  2. Click Start, point to Programs, and then click Windows Explorer.

    NOTE: In Microsoft Windows NT, point to Programs, point to the Accessories folder, and then click Windows Explorer.
  3. Open your CD-ROM drive and navigate to the following folder:
    drive\Files\Osp\1033\IE5\En
  4. Double-click Oainst.exe.NOTE: The preceding steps install the OLE automation update, which includes the file Asycfilt.dll. The following steps ensure that all your system files are updated.

  5. In Windows Explorer, open Control Panel under My Computer, and then double-click Add/Remove Programs.
  6. Double-click the System Files Update entry in the Add/Remove Program Properties dialog box.NOTE: If the System Files Update has been uninstalled or is not listed in the Add/Remove Program Properties dialog box, you must install the System Files Update before you continue with these steps. To install the System Files Update, follow these steps:

    1. Open the \Files\OSP\1033 folder from the root of the Office source files location.
    2. Right-click OSP.msi, and then click Install.
    3. When you are prompted to restart the computer, click Yes. After the System Files Update is installed, go back to step 5 and continue.
  7. In the Maintenance Mode Options dialog box, click Repair System Files Update, and then click Next.
  8. In the Reinstall or Repair System Files Update installation dialog box, click Reinstall System Files Update, and then click Install.
  9. When the repair of the System Files Update finishes, repair your Office installation by using either the Repair Office button in Maintenance Mode Setup or Detect and Repair on the Help menu in any Office program.

STATUS

This problem was corrected in Office 97 File and Registry Eraser Utility version 4.0.

MORE INFORMATION

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
295345 OFFXP: Error 25510, Asycfilt.dll Missing When You Run Office Setup
NOTE: Eraser does not run on operating systems later than Microsoft Windows 2000.

REFERENCES

For more articles about troubleshooting Setup issues with Office XP:
Click here to view a list of Troubleshooting Installation of Office XP: Pick Your Operating System articles

Properties

Article ID: 299066 - Last Review: December 4, 2007 - Revision: 5.2
APPLIES TO
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows NT 4.0
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Standard Edition for Students and Teachers
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbtshoot kbsetup kberrmsg KB299066

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com